{"answers":{"affected":"2 open source packages ship an affected version, including flowise. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-70474 exists.","fix":"Upgrade flowise to 3.1.3 or later.","what":"CVE-2026-70474 is a high-severity missing authorization vulnerability in Flowiseai Flowise, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-70474 and fix it if it is affected.\n\nWhat it is: CVE-2026-70474 is a high-severity missing authorization vulnerability in Flowiseai Flowise, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-70474 exists.\n\nAffected packages and fixed versions:\n- flowise (npm): affected all versions; fixed in 3.1.3\n- flowise (npm): affected all versions; fixed in 3.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-70474/ (Markdown: https://insights.sbomify.com/CVE-2026-70474/index.md)","id":"CVE-2026-70474","markdown":"https://insights.sbomify.com/CVE-2026-70474/index.md","name":"CVE-2026-70474","record":{"aliases":["GHSA-wch5-xp77-fxg4"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM flow builder","requires_auth":"low_privilege","summary":"Attackers can access or modify OAuth2 credentials across workspaces due to missing workspace ID checks in API endpoints.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"flowise","vendor":"flowiseai"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Flowise is a drag-and-drop user interface for building customized large language model (LLM) flows. Prior to 3.1.3, Flowise has three OAuth2 credential endpoints that look up credentials by id alone with no workspaceId filter. The authorize, callback, and refresh handlers query the Credential table by id only; callback and refresh are whitelisted from authentication. This allows any authenticated user to initiate OAuth2 flows against credentials belonging to other workspaces, allows an unauthenticated attacker to forge OAuth2 callbacks to overwrite tokens in any credential, and allows an unauthenticated attacker to refresh tokens for any credential. The affected routes include /api/v1/oauth2-credential/authorize/\u003cVICTIM_CREDENTIAL_UUID\u003e, /api/v1/oauth2-credential/callback?code=ATTACKER_AUTH_CODE\u0026state=\u003cVICTIM_CREDENTIAL_UUID\u003e, and /api/v1/oauth2-credential/refresh/\u003cVICTIM_CREDENTIAL_UUID\u003e. This issue is fixed in version 3.1.3.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Flowise: Cross-Workspace OAuth2 Credential Metadata Leak","id":"CVE-2026-70474","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"flowiseai:flowise","products":["flowiseai:flowise"],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Flowise: Missing Authorization on Execution Update Endpoint","id":"CVE-2026-70475"},"packages":[{"ecosystem":"npm","fixed":["3.1.3"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":null,"source":"GHSA-wch5-xp77-fxg4"},{"ecosystem":"npm","fixed":["3.1.3"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":"pkg:npm/flowise","source":"GHSA-wch5-xp77-fxg4"}],"prev":{"headline":"Flowise: Information Disclosure in GET /api/v1/upsert-history returns the entire server-wide upsert history","id":"CVE-2026-70473"},"products":["Flowise"],"published":"2026-08-04","related":[{"cvss_score":10,"headline":"Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API","id":"CVE-2025-71338","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":10,"headline":"Flowise: Authenticated RCE Via MCP Adapters","id":"CVE-2026-40933","kev_date_added":null,"published":"2026-04-21"},{"cvss_score":10,"headline":"Flowise is vulnerable to arbitrary file read, arbitrary file write","id":"CVE-2025-61913","kev_date_added":null,"published":"2025-10-08"},{"cvss_score":10,"headline":"Flowise has Remote Code Execution vulnerability","id":"CVE-2025-59528","kev_date_added":null,"published":"2025-09-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2026-52098","kev_date_added":null,"published":"2026-09-10"},{"cvss_score":9.8,"headline":"Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover","id":"CVE-2025-58434","kev_date_added":null,"published":"2025-09-12"},{"cvss_score":9.8,"headline":"Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers","id":"CVE-2025-8943","kev_date_added":null,"published":"2025-08-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-05","vendors":["FlowiseAI"]},"summary":"Attackers can access or modify OAuth2 credentials across workspaces due to missing workspace ID checks in API endpoints.","url":"https://insights.sbomify.com/CVE-2026-70474/"}