# CVE-2026-70474: Flowise: Cross-Workspace OAuth2 Credential Metadata Leak

> Attackers can access or modify OAuth2 credentials across workspaces due to missing workspace ID checks in API endpoints.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-wch5-xp77-fxg4

## What is CVE-2026-70474?

CVE-2026-70474 is a high-severity missing authorization vulnerability in Flowiseai Flowise, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flowise is a drag-and-drop user interface for building customized large language model (LLM) flows. Prior to 3.1.3, Flowise has three OAuth2 credential endpoints that look up credentials by id alone with no workspaceId filter. The authorize, callback, and refresh handlers query the Credential table by id only; callback and refresh are whitelisted from authentication. This allows any authenticated user to initiate OAuth2 flows against credentials belonging to other workspaces, allows an unauthenticated attacker to forge OAuth2 callbacks to overwrite tokens in any credential, and allows an unauthenticated attacker to refresh tokens for any credential. The affected routes include /api/v1/oauth2-credential/authorize/<VICTIM_CREDENTIAL_UUID>, /api/v1/oauth2-credential/callback?code=ATTACKER_AUTH_CODE&state=<VICTIM_CREDENTIAL_UUID>, and /api/v1/oauth2-credential/refresh/<VICTIM_CREDENTIAL_UUID>. This issue is fixed in version 3.1.3.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-70474?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.1.3 |
| `flowise` | npm | All versions | 3.1.3 |

Products: Flowiseai Flowise.

## How do I fix CVE-2026-70474?

Upgrade flowise to 3.1.3 or later.

## Is CVE-2026-70474 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-70474 exists.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70474 and fix it if it is affected.

What it is: CVE-2026-70474 is a high-severity missing authorization vulnerability in Flowiseai Flowise, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-70474 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.1.3
- flowise (npm): affected all versions; fixed in 3.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70474/ (Markdown: https://insights.sbomify.com/CVE-2026-70474/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70474
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70474
- OSV: https://osv.dev/vulnerability/CVE-2026-70474

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70474/
Summaries are generated and may contain mistakes; the official description above is the record.
