# CVE-2026-70477: Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability

> Attackers can execute arbitrary Python code via prompt injection in Flowise CSV Agent nodes, compromising the service account.

- **Severity:** Critical 9.5 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-5xvg-pmgg-3mxr

## What is CVE-2026-70477?

CVE-2026-70477 is a critical code injection vulnerability in Flowiseai Flowise, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, a prompt injection sent to a chatflow using a CSV Agent node can cause the LLM to respond with a malicious Python script that bypasses the blocklist validator and executes in an unsandboxed Pyodide environment. The specific flaw exists within the run method of the CSV_Agents class, where untrusted data is used to construct an LLM prompt and the resulting pythonCode is validated by validatePythonCodeForDataFrame before execution. An attacker can leverage this to execute arbitrary code in the context of the service account. This issue is fixed in 3.1.3.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-70477?

4 open source packages ship an affected version, including flowise and flowise-components. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.1.3 |
| `flowise` | npm | All versions | 3.1.3 |
| `flowise-components` | npm | All versions | 3.1.3 |
| `flowise-components` | npm | All versions | 3.1.3 |

Products: Flowiseai Flowise.

## How do I fix CVE-2026-70477?

Upgrade flowise to 3.1.3 or later.

## Is CVE-2026-70477 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-70477 exists.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70477 and fix it if it is affected.

What it is: CVE-2026-70477 is a critical code injection vulnerability in Flowiseai Flowise, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-70477 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.1.3
- flowise (npm): affected all versions; fixed in 3.1.3
- flowise-components (npm): affected all versions; fixed in 3.1.3
- flowise-components (npm): affected all versions; fixed in 3.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70477/ (Markdown: https://insights.sbomify.com/CVE-2026-70477/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70477
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70477
- OSV: https://osv.dev/vulnerability/CVE-2026-70477

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70477/
Summaries are generated and may contain mistakes; the official description above is the record.
