# CVE-2026-70480: Open WebUI: Client-side SSRF via unrestricted external resource loading in Vega/Vega-Lite chart rendering

> Attackers can force victim browsers to make unauthorized outbound requests and read responses via malicious Vega chart rendering in Open WebUI.

- **Severity:** Medium 4.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-rffm-9q57-q649, PYSEC-2026-3651

## What is CVE-2026-70480?

CVE-2026-70480 is a medium-severity server-side request forgery vulnerability in Openwebui Open Webui, published on 4 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Open WebUI is an extensible, feature-rich, and user-friendly self-hosted AI platform. From 0.6.34 until 0.11.0, Open WebUI renders vega and vega-lite fenced code blocks in chat content by building a Vega view in the viewer browser without a restricted resource loader. Any user who can place such a block where another user will see it can make that user browser issue attacker-chosen outbound GET requests and read responses from same-origin or CORS-permissive targets into the rendered page. This issue is fixed in 0.11.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-70480?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | From 0.6.34 | 0.11.0 |
| `open-webui` | PyPI | From 0.6.34 | 0.11.0 |
| `open-webui` | PyPI | From 0.6.34 | 0.11.0 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-70480?

Upgrade open-webui to 0.11.0 or later.

## Is CVE-2026-70480 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-70480 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70480 and fix it if it is affected.

What it is: CVE-2026-70480 is a medium-severity server-side request forgery vulnerability in Openwebui Open Webui, published on 4 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-70480 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected from 0.6.34; fixed in 0.11.0
- open-webui (PyPI): affected from 0.6.34; fixed in 0.11.0
- open-webui (PyPI): affected from 0.6.34; fixed in 0.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70480/ (Markdown: https://insights.sbomify.com/CVE-2026-70480/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70480
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70480
- OSV: https://osv.dev/vulnerability/CVE-2026-70480

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70480/
Summaries are generated and may contain mistakes; the official description above is the record.
