# CVE-2026-70490: Open WebUI: Unapproved accounts can open terminal sessions via a WebSocket auth path missing the role check

> Unapproved accounts can bypass role checks to open terminal sessions, enabling unauthorized code execution if terminal servers are configured.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-5gpj-vj23-vhhv, PYSEC-2026-3642

## What is CVE-2026-70490?

CVE-2026-70490 is a medium-severity missing authorization vulnerability in Openwebui Open Webui, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open WebUI is an extensible, feature-rich, and user-friendly self-hosted AI platform. From 0.8.8 until 0.11.0, the terminal WebSocket route in backend/open_webui/routers/terminals.py authenticated its own first-message JWT and never applied the verified-user role gate that get_verified_user enforces on HTTP terminal routes. An account whose role is pending, including a registered but unapproved account or an account deactivated back to pending, can open an interactive terminal session when at least one terminal server is configured and its access grants cover the account. This loses the account-approval boundary for terminal access while the HTTP terminal routes correctly reject the same account. This issue is fixed in 0.11.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-70490?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | From 0.8.8 | 0.11.0 |
| `open-webui` | PyPI | From 0.8.8 | 0.11.0 |
| `open-webui` | PyPI | From 0.8.8 | 0.11.0 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-70490?

Upgrade open-webui to 0.11.0 or later.

## Is CVE-2026-70490 being exploited?

There is no known exploitation of CVE-2026-70490 in the wild and no public exploit code.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70490 and fix it if it is affected.

What it is: CVE-2026-70490 is a medium-severity missing authorization vulnerability in Openwebui Open Webui, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-70490 in the wild and no public exploit code.

Affected packages and fixed versions:
- open-webui (PyPI): affected from 0.8.8; fixed in 0.11.0
- open-webui (PyPI): affected from 0.8.8; fixed in 0.11.0
- open-webui (PyPI): affected from 0.8.8; fixed in 0.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70490/ (Markdown: https://insights.sbomify.com/CVE-2026-70490/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70490
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70490
- OSV: https://osv.dev/vulnerability/CVE-2026-70490

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70490/
Summaries are generated and may contain mistakes; the official description above is the record.
