# CVE-2026-70492: Open WebUI: Stored XSS via unescaped KaTeX render-error fallback in rendered messages

> Attackers can inject malicious scripts via KaTeX error fallbacks in chat messages, stealing session tokens or taking over admin accounts.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-pwxh-7358-jq2x, PYSEC-2026-3650

## What is CVE-2026-70492?

CVE-2026-70492 is a high-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 4 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Open WebUI is an extensible, feature-rich, and user-friendly self-hosted AI platform. From 0.10.0 until 0.11.0, src/lib/components/chat/Messages/Markdown/KatexRenderer.svelte could store and render a chat message whose math block makes KaTeX fail with a stack overflow instead of a parse error. The catch branch fell back to inserting the original math source into the page as HTML through {@html} rather than as text, so script in the message runs in the browser of whoever views it, including shared chats and channels. The viewer's session token in localStorage can be stolen, and an administrator viewer can have their account taken over. This issue is fixed in 0.11.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-70492?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | From 0.10.0 | 0.11.0 |
| `open-webui` | PyPI | From 0.10.0 | 0.11.0 |
| `open-webui` | PyPI | From 0.10.0 | 0.11.0 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-70492?

Upgrade open-webui to 0.11.0 or later.

## Is CVE-2026-70492 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-70492 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70492 and fix it if it is affected.

What it is: CVE-2026-70492 is a high-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 4 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-70492 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected from 0.10.0; fixed in 0.11.0
- open-webui (PyPI): affected from 0.10.0; fixed in 0.11.0
- open-webui (PyPI): affected from 0.10.0; fixed in 0.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70492/ (Markdown: https://insights.sbomify.com/CVE-2026-70492/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70492
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70492
- OSV: https://osv.dev/vulnerability/CVE-2026-70492

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70492/
Summaries are generated and may contain mistakes; the official description above is the record.
