{"answers":{"affected":"3 open source packages ship an affected version, including ghost.","exploited":"There is no known exploitation of CVE-2026-70588 in the wild and no public exploit code.","fix":"Upgrade ghost to 6.54.1 or later.","what":"CVE-2026-70588 is a medium-severity cross-site scripting vulnerability in TryGhost Ghost, published on 4 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-70588 and fix it if it is affected.\n\nWhat it is: CVE-2026-70588 is a medium-severity cross-site scripting vulnerability in TryGhost Ghost, published on 4 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-70588 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ghost (Bitnami): affected from 5.26.0; fixed in 6.54.1\n- ghost (npm): affected from 5.26.0; fixed in 6.54.1\n- ghost (npm): affected from 5.26.0; fixed in 6.54.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-70588/ (Markdown: https://insights.sbomify.com/CVE-2026-70588/index.md)","id":"CVE-2026-70588","markdown":"https://insights.sbomify.com/CVE-2026-70588/index.md","name":"CVE-2026-70588","record":{"aliases":["BIT-ghost-2026-70588","GHSA-2gx6-7gx2-wwcf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Ghost CMS","requires_auth":"high_privilege","summary":"Attackers can inject malicious scripts via the Universal Import feature in Ghost Admin, potentially compromising user sessions and data.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Ghost is a Node.js content management system. From 5.26.0 until 6.54.1, the Universal Import feature in Ghost Admin failed to properly sanitize imported content resulting in XSS in post content. This issue is fixed in version 6.54.1.","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ghost: Cross-Site Scripting in Universal Import","id":"CVE-2026-70588","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Ghost: Archived Offers can be Redeemed","id":"CVE-2026-70589"},"packages":[{"ecosystem":"Bitnami","fixed":["6.54.1"],"introduced":["5.26.0"],"last_affected":[],"package":"ghost","purl":"pkg:bitnami/ghost","source":"BIT-ghost-2026-70588"},{"ecosystem":"npm","fixed":["6.54.1"],"introduced":["5.26.0"],"last_affected":[],"package":"ghost","purl":null,"source":"GHSA-2gx6-7gx2-wwcf"},{"ecosystem":"npm","fixed":["6.54.1"],"introduced":["5.26.0"],"last_affected":[],"package":"ghost","purl":"pkg:npm/ghost","source":"GHSA-2gx6-7gx2-wwcf"}],"prev":{"headline":"Windows Remote Desktop Protocol Information Disclosure Vulnerability","id":"CVE-2026-70587"},"products":["Ghost"],"published":"2026-08-04","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-05","vendors":["TryGhost"]},"summary":"Attackers can inject malicious scripts via the Universal Import feature in Ghost Admin, potentially compromising user sessions and data.","url":"https://insights.sbomify.com/CVE-2026-70588/"}