# CVE-2026-70588: Ghost: Cross-Site Scripting in Universal Import

> Attackers can inject malicious scripts via the Universal Import feature in Ghost Admin, potentially compromising user sessions and data.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** BIT-ghost-2026-70588, GHSA-2gx6-7gx2-wwcf

## What is CVE-2026-70588?

CVE-2026-70588 is a medium-severity cross-site scripting vulnerability in TryGhost Ghost, published on 4 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Ghost is a Node.js content management system. From 5.26.0 until 6.54.1, the Universal Import feature in Ghost Admin failed to properly sanitize imported content resulting in XSS in post content. This issue is fixed in version 6.54.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-70588?

3 open source packages ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 5.26.0 | 6.54.1 |
| `ghost` | npm | From 5.26.0 | 6.54.1 |
| `ghost` | npm | From 5.26.0 | 6.54.1 |

## How do I fix CVE-2026-70588?

Upgrade ghost to 6.54.1 or later.

## Is CVE-2026-70588 being exploited?

There is no known exploitation of CVE-2026-70588 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70588 and fix it if it is affected.

What it is: CVE-2026-70588 is a medium-severity cross-site scripting vulnerability in TryGhost Ghost, published on 4 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-70588 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 5.26.0; fixed in 6.54.1
- ghost (npm): affected from 5.26.0; fixed in 6.54.1
- ghost (npm): affected from 5.26.0; fixed in 6.54.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70588/ (Markdown: https://insights.sbomify.com/CVE-2026-70588/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70588
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70588
- OSV: https://osv.dev/vulnerability/CVE-2026-70588

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70588/
Summaries are generated and may contain mistakes; the official description above is the record.
