# CVE-2026-70591: Ghost: Server-Side Request Forgery in Image Fetching

> Staff users can perform blind HTTP GET requests to internal hosts via image fetching, enabling internal network probing.

- **Severity:** Medium 4.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** BIT-ghost-2026-70591, GHSA-gcvv-72q8-9v76

## What is CVE-2026-70591?

CVE-2026-70591 is a medium-severity server-side request forgery vulnerability in TryGhost Ghost, published on 4 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Ghost is a Node.js content management system. From 0.10.0 until 6.54.1, a Server-Side Request Forgery in Ghost Admin image fetching allowed any staff-level user to perform a blind HTTP GET request against internal hosts. No output was returned, but this could have been used to probe open ports on internal hosts. This issue is fixed in version 6.54.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-70591?

3 open source packages ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 0.10.0 | 6.54.1 |
| `ghost` | npm | From 0.10.0 | 6.54.1 |
| `ghost` | npm | From 0.10.0 | 6.54.1 |

## How do I fix CVE-2026-70591?

Upgrade ghost to 6.54.1 or later.

## Is CVE-2026-70591 being exploited?

There is no known exploitation of CVE-2026-70591 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70591 and fix it if it is affected.

What it is: CVE-2026-70591 is a medium-severity server-side request forgery vulnerability in TryGhost Ghost, published on 4 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-70591 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 0.10.0; fixed in 6.54.1
- ghost (npm): affected from 0.10.0; fixed in 6.54.1
- ghost (npm): affected from 0.10.0; fixed in 6.54.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70591/ (Markdown: https://insights.sbomify.com/CVE-2026-70591/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70591
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70591
- OSV: https://osv.dev/vulnerability/CVE-2026-70591

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70591/
Summaries are generated and may contain mistakes; the official description above is the record.
