# CVE-2026-70593: Ghost: Theme Upload Path Traversal

> A staff user can exploit path traversal in custom theme uploads to write files outside the intended directory, potentially altering installation behavior.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** BIT-ghost-2026-70593, GHSA-cjc9-q5gf-327p

## What is CVE-2026-70593?

CVE-2026-70593 is a medium-severity path traversal vulnerability in TryGhost Ghost, published on 4 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Ghost is a Node.js content management system. From 0.10.0 until 6.54.1, a vulnerability in custom themes allowed a staff user to write files outside of the uploads directory. This could be used to alter the behavior of the installation through custom theme upload path traversal in LocalStorageBase and theme storage name handling. This issue is fixed in version 6.54.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-70593?

3 open source packages ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 0.10.0 | 6.54.1 |
| `ghost` | npm | From 0.10.0 | 6.54.1 |
| `ghost` | npm | From 0.10.0 | 6.54.1 |

## How do I fix CVE-2026-70593?

Upgrade ghost to 6.54.1 or later.

## Is CVE-2026-70593 being exploited?

There is no known exploitation of CVE-2026-70593 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70593 and fix it if it is affected.

What it is: CVE-2026-70593 is a medium-severity path traversal vulnerability in TryGhost Ghost, published on 4 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-70593 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 0.10.0; fixed in 6.54.1
- ghost (npm): affected from 0.10.0; fixed in 6.54.1
- ghost (npm): affected from 0.10.0; fixed in 6.54.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70593/ (Markdown: https://insights.sbomify.com/CVE-2026-70593/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70593
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70593
- OSV: https://osv.dev/vulnerability/CVE-2026-70593

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70593/
Summaries are generated and may contain mistakes; the official description above is the record.
