# CVE-2026-70596: Ghost: Cross-Site Scripting in Feature Image Captions

> An XSS vulnerability in Ghost CMS allows staff users to hijack other staff sessions via feature image captions, leading to privilege escalation.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** BIT-ghost-2026-70596, GHSA-pr22-p9rp-2cqv

## What is CVE-2026-70596?

CVE-2026-70596 is a medium-severity cross-site scripting vulnerability in TryGhost Ghost, published on 5 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Ghost is a Node.js content management system. From 4.9.0 until 6.54.1, an input validation issue allowed any staff user to create a post with content in feature_image_caption that could be used to hijack another staff user's Ghost Admin session, resulting in privilege escalation. This issue is fixed in 6.54.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-70596?

3 open source packages ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 4.9.0 | 6.54.1 |
| `ghost` | npm | From 4.9.0 | 6.54.1 |
| `ghost` | npm | From 4.9.0 | 6.54.1 |

## How do I fix CVE-2026-70596?

Upgrade ghost to 6.54.1 or later.

## Is CVE-2026-70596 being exploited?

There is no known exploitation of CVE-2026-70596 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70596 and fix it if it is affected.

What it is: CVE-2026-70596 is a medium-severity cross-site scripting vulnerability in TryGhost Ghost, published on 5 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-70596 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 4.9.0; fixed in 6.54.1
- ghost (npm): affected from 4.9.0; fixed in 6.54.1
- ghost (npm): affected from 4.9.0; fixed in 6.54.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70596/ (Markdown: https://insights.sbomify.com/CVE-2026-70596/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70596
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70596
- OSV: https://osv.dev/vulnerability/CVE-2026-70596

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70596/
Summaries are generated and may contain mistakes; the official description above is the record.
