# CVE-2026-70598: Electron: Off-screen rendering trusts GPU-supplied geometry over shared-memory size

> A compromised GPU process can cause out-of-bounds memory reads in the main process, leading to information disclosure or application crashes.

- **Severity:** Low 3.9 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-pfmc-3mgc-p6fp

## What is CVE-2026-70598?

CVE-2026-70598 is a low-severity memory corruption vulnerability in Electronjs Electron, published on 5 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. Prior to 39.8.10, 40.9.0, 41.2.1, and 42.0.0-beta.3, offscreen rendering frame data received from the GPU process was not fully validated by the main process. A compromised GPU process could cause the main process to read out-of-bounds memory while producing paint event images, disclosing memory or crashing the app. This issue is fixed in 39.8.10, 40.9.0, 41.2.1, and 42.0.0-beta.3.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-70598?

8 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | All versions | 39.8.10 |
| `electron` | npm | All versions | 39.8.10 |
| `electron` | npm | From 40.0.0-alpha.1 | 40.9.0 |
| `electron` | npm | From 40.0.0-alpha.1 | 40.9.0 |
| `electron` | npm | From 41.0.0-alpha.1 | 41.2.1 |
| `electron` | npm | From 41.0.0-alpha.1 | 41.2.1 |
| `electron` | npm | From 42.0.0-alpha.1 | 42.0.0-beta.3 |
| `electron` | npm | From 42.0.0-alpha.1 | 42.0.0-beta.3 |

Products: Electronjs Electron.

## How do I fix CVE-2026-70598?

Upgrade electron to a fixed version for your release line: 39.8.10, 40.9.0, 41.2.1 or 42.0.0-beta.3.

## Is CVE-2026-70598 being exploited?

There is no known exploitation of CVE-2026-70598 in the wild and no public exploit code.

## Other vulnerabilities in Electronjs Electron

- [CVE-2017-16151](https://insights.sbomify.com/CVE-2017-16151/): Chromium Remote Code Execution in electron (critical 9.8)
- [CVE-2018-1000118](https://insights.sbomify.com/CVE-2018-1000118/): Electron protocol handler browser vulnerable to Command Injection (high 8.8)
- [CVE-2026-34780](https://insights.sbomify.com/CVE-2026-34780/): Electron: Context Isolation bypass via contextBridge VideoFrame transfer (high 8.4)
- [CVE-2026-102676](https://insights.sbomify.com/CVE-2026-102676/): Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions (high 8.3)
- [CVE-2026-102673](https://insights.sbomify.com/CVE-2026-102673/): Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70598 and fix it if it is affected.

What it is: CVE-2026-70598 is a low-severity memory corruption vulnerability in Electronjs Electron, published on 5 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-70598 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected all versions; fixed in 39.8.10
- electron (npm): affected all versions; fixed in 39.8.10
- electron (npm): affected from 40.0.0-alpha.1; fixed in 40.9.0
- electron (npm): affected from 40.0.0-alpha.1; fixed in 40.9.0
- electron (npm): affected from 41.0.0-alpha.1; fixed in 41.2.1
- electron (npm): affected from 41.0.0-alpha.1; fixed in 41.2.1
- electron (npm): affected from 42.0.0-alpha.1; fixed in 42.0.0-beta.3
- electron (npm): affected from 42.0.0-alpha.1; fixed in 42.0.0-beta.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70598/ (Markdown: https://insights.sbomify.com/CVE-2026-70598/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70598
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70598
- OSV: https://osv.dev/vulnerability/CVE-2026-70598

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70598/
Summaries are generated and may contain mistakes; the official description above is the record.
