# CVE-2026-70599: Electron: Permission Check Handler Receives Main Frame Origin Instead of Requesting Iframe Origin

> Electron developers must upgrade to prevent cross-origin iframes from bypassing permission checks for serial and media devices.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-9pf5-hg6p-4pwp

## What is CVE-2026-70599?

CVE-2026-70599 is a medium-severity vulnerability in Electronjs Electron, published on 5 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. Prior to 39.8.7, 40.9.0, 41.2.0, and 42.0.0-beta.1, serial-port and media permission checks made from an iframe passed the top-level frame origin to session.setPermissionCheckHandler instead of the requesting iframe origin. Origin-based handler logic could grant a cross-origin iframe device access intended only for the top-level origin. This issue is fixed in 39.8.7, 40.9.0, 41.2.0, and 42.0.0-beta.1.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-70599?

8 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | All versions | 39.8.7 |
| `electron` | npm | All versions | 39.8.7 |
| `electron` | npm | From 40.0.0-alpha.1 | 40.9.0 |
| `electron` | npm | From 40.0.0-alpha.1 | 40.9.0 |
| `electron` | npm | From 41.0.0-alpha.1 | 41.2.0 |
| `electron` | npm | From 41.0.0-alpha.1 | 41.2.0 |
| `electron` | npm | From 42.0.0-alpha.1 | 42.0.0-beta.1 |
| `electron` | npm | From 42.0.0-alpha.1 | 42.0.0-beta.1 |

Products: Electronjs Electron.

## How do I fix CVE-2026-70599?

Upgrade electron to a fixed version for your release line: 39.8.7, 40.9.0, 41.2.0 or 42.0.0-beta.1.

## Is CVE-2026-70599 being exploited?

There is no known exploitation of CVE-2026-70599 in the wild and no public exploit code.

## Other vulnerabilities in Electronjs Electron

- [CVE-2017-16151](https://insights.sbomify.com/CVE-2017-16151/): Chromium Remote Code Execution in electron (critical 9.8)
- [CVE-2018-1000118](https://insights.sbomify.com/CVE-2018-1000118/): Electron protocol handler browser vulnerable to Command Injection (high 8.8)
- [CVE-2026-34780](https://insights.sbomify.com/CVE-2026-34780/): Electron: Context Isolation bypass via contextBridge VideoFrame transfer (high 8.4)
- [CVE-2026-102676](https://insights.sbomify.com/CVE-2026-102676/): Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions (high 8.3)
- [CVE-2026-102673](https://insights.sbomify.com/CVE-2026-102673/): Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70599 and fix it if it is affected.

What it is: CVE-2026-70599 is a medium-severity vulnerability in Electronjs Electron, published on 5 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-70599 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected all versions; fixed in 39.8.7
- electron (npm): affected all versions; fixed in 39.8.7
- electron (npm): affected from 40.0.0-alpha.1; fixed in 40.9.0
- electron (npm): affected from 40.0.0-alpha.1; fixed in 40.9.0
- electron (npm): affected from 41.0.0-alpha.1; fixed in 41.2.0
- electron (npm): affected from 41.0.0-alpha.1; fixed in 41.2.0
- electron (npm): affected from 42.0.0-alpha.1; fixed in 42.0.0-beta.1
- electron (npm): affected from 42.0.0-alpha.1; fixed in 42.0.0-beta.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70599/ (Markdown: https://insights.sbomify.com/CVE-2026-70599/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70599
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70599
- OSV: https://osv.dev/vulnerability/CVE-2026-70599

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70599/
Summaries are generated and may contain mistakes; the official description above is the record.
