# CVE-2026-70600: Electron: Cross-origin iframe can position native autofill popup

> Cross-origin iframes can spoof trusted UI via native autofill popups, enabling clickjacking in Electron apps embedding untrusted content.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Aug 2026
- **Updated:** 6 Aug 2026
- **Also known as:** GHSA-x8rc-wpg4-grpf

## What is CVE-2026-70600?

CVE-2026-70600 is a low-severity vulnerability in Electronjs Electron, published on 5 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. Prior to 39.8.8, 40.9.0, 41.2.1, and 42.0.0-beta.3, the native autofill popup could be positioned by a cross-origin iframe outside that iframe's bounds, over the embedding page's UI, enabling clickjacking or spoofing of trusted UI. Apps are only affected if they embed untrusted content in iframes within windows that also display trusted UI. Apps that do not embed untrusted third-party content are not affected. This issue is fixed in versions 39.8.8, 40.9.0, 41.2.1, and 42.0.0-beta.3.

Weakness: CWE-1021 (Improper Restriction of Rendered UI Layers or Frames)

## Which versions are affected by CVE-2026-70600?

8 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | All versions | 39.8.8 |
| `electron` | npm | All versions | 39.8.8 |
| `electron` | npm | From 40.0.0-alpha.1 | 40.9.1 |
| `electron` | npm | From 40.0.0-alpha.1 | 40.9.1 |
| `electron` | npm | From 41.0.0-alpha.1 | 41.2.1 |
| `electron` | npm | From 41.0.0-alpha.1 | 41.2.1 |
| `electron` | npm | From 42.0.0-alpha.1 | 42.0.0-beta.3 |
| `electron` | npm | From 42.0.0-alpha.1 | 42.0.0-beta.3 |

Products: Electronjs Electron.

## How do I fix CVE-2026-70600?

Upgrade electron to a fixed version for your release line: 39.8.8, 40.9.1, 41.2.1 or 42.0.0-beta.3.

## Is CVE-2026-70600 being exploited?

There is no known exploitation of CVE-2026-70600 in the wild and no public exploit code.

## Other vulnerabilities in Electronjs Electron

- [CVE-2017-16151](https://insights.sbomify.com/CVE-2017-16151/): Chromium Remote Code Execution in electron (critical 9.8)
- [CVE-2018-1000118](https://insights.sbomify.com/CVE-2018-1000118/): Electron protocol handler browser vulnerable to Command Injection (high 8.8)
- [CVE-2026-34780](https://insights.sbomify.com/CVE-2026-34780/): Electron: Context Isolation bypass via contextBridge VideoFrame transfer (high 8.4)
- [CVE-2026-102676](https://insights.sbomify.com/CVE-2026-102676/): Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions (high 8.3)
- [CVE-2026-102673](https://insights.sbomify.com/CVE-2026-102673/): Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70600 and fix it if it is affected.

What it is: CVE-2026-70600 is a low-severity vulnerability in Electronjs Electron, published on 5 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-70600 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected all versions; fixed in 39.8.8
- electron (npm): affected all versions; fixed in 39.8.8
- electron (npm): affected from 40.0.0-alpha.1; fixed in 40.9.1
- electron (npm): affected from 40.0.0-alpha.1; fixed in 40.9.1
- electron (npm): affected from 41.0.0-alpha.1; fixed in 41.2.1
- electron (npm): affected from 41.0.0-alpha.1; fixed in 41.2.1
- electron (npm): affected from 42.0.0-alpha.1; fixed in 42.0.0-beta.3
- electron (npm): affected from 42.0.0-alpha.1; fixed in 42.0.0-beta.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70600/ (Markdown: https://insights.sbomify.com/CVE-2026-70600/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70600
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70600
- OSV: https://osv.dev/vulnerability/CVE-2026-70600

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70600/
Summaries are generated and may contain mistakes; the official description above is the record.
