CVE-2026-70610 Electron: contextBridge object copy honors prototype setters
Attackers can execute arbitrary code in Electron preload scripts via prototype pollution if apps accept untrusted object arguments without validation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-70610?
CVE-2026-70610 is a medium-severity code injection vulnerability in Electronjs Electron, published on 5 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. Prior to 39.8.9, 40.9.2, 41.2.2, and 42.0.0-beta.4, objects copied across the contextBridge boundary from untrusted content could carry an attacker-influenced prototype, enabling prototype-pollution-style attacks against preload code despite context isolation being enabled. Apps are only affected if their preload code accepts object arguments from untrusted content and reads properties from them without own-property checks, while apps that only accept primitive arguments or validate object arguments are not affected. This issue is fixed in 39.8.9, 40.9.2, 41.2.2, and 42.0.0-beta.4.
Weakness: CWE-1321
Which versions are affected by CVE-2026-70610?
8 open source packages ship an affected version, including electron. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
electron npm | All versions | 39.8.9 |
electron npm | All versions | 39.8.9 |
electron npm | From 40.0.0-alpha.1 | 40.9.2 |
electron npm | From 40.0.0-alpha.1 | 40.9.2 |
electron npm | From 41.0.0-alpha.1 | 41.2.2 |
electron npm | From 41.0.0-alpha.1 | 41.2.2 |
2 more packages
electron npm | From 42.0.0-alpha.1 | 42.0.0-beta.4 |
electron npm | From 42.0.0-alpha.1 | 42.0.0-beta.4 |
Products include Electronjs Electron.
How do I fix CVE-2026-70610?
Upgrade electron to a fixed version for your release line: 39.8.9, 40.9.2, 41.2.2 or 42.0.0-beta.4.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-70610 being exploited?
There is no known exploitation of CVE-2026-70610 in the wild and no public exploit code.
Other vulnerabilities in Electronjs Electron
- CVE-2017-16151 Chromium Remote Code Execution in electron
- CVE-2018-1000118 Electron protocol handler browser vulnerable to Command Injection
- CVE-2026-34780 Electron: Context Isolation bypass via contextBridge VideoFrame transfer
- CVE-2026-102676 Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions
- CVE-2026-102673 Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab
Sources
Also known as GHSA-ff2p-hmqr-hxm4.