# CVE-2026-7064: AgentDeskAI browser-tools-mcp browser-connector.ts os command injection


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 26 Apr 2026
- **Updated:** 2 Oct 2026
- **Also known as:** GHSA-v8rp-xp3h-qjf9, GHSA-xvrv-w8pg-f25f

## What is CVE-2026-7064?

CVE-2026-7064 is a medium-severity vulnerability in AgentDeskAI browser-tools-mcp, published on 26 Apr 2026. 

### Official description

A flaw has been found in AgentDeskAI browser-tools-mcp up to 1.2.0. This issue affects some unknown processing of the file browser-tools-server/browser-connector.ts. Executing a manipulation can lead to os command injection. The attack may be performed from remote. The exploit has been published and may be used. Upgrading to version 2.0.0 is capable of addressing this issue. It is recommended to upgrade the affected component.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-7064?


## How do I fix CVE-2026-7064?

No fix has been published for CVE-2026-7064 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-7064 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7064 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7064 and fix it if it is affected.

What it is: CVE-2026-7064 is a medium-severity vulnerability in AgentDeskAI browser-tools-mcp, published on 26 Apr 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7064 exists.

Affected product: AgentDeskAI browser-tools-mcp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7064/ (Markdown: https://insights.sbomify.com/CVE-2026-7064/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7064
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7064
- OSV: https://osv.dev/vulnerability/CVE-2026-7064

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7064/
Summaries are generated and may contain mistakes; the official description above is the record.
