# CVE-2026-70646: aiosend: Deserialization of request body before signature verification (Pre-auth DoS) in webhook handler

> Unauthenticated attackers can cause denial of service in aiosend by sending large JSON payloads that are parsed before signature verification.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 8 Aug 2026
- **Also known as:** GHSA-7m8f-hgjq-8gc9, PYSEC-2026-3626

## What is CVE-2026-70646?

CVE-2026-70646 is a high-severity denial of service vulnerability in vovchic17 aiosend, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

aiosend is a synchronous and asynchronous Crypto Pay API client. Pror to version 3.0.7, `WebhookHandler.feed_update()` deserializes the entire request body before verifying the HMAC signature. This allows an unauthenticated attacker to force expensive parsing of arbitrary JSON payloads that will ultimately be rejected, leading to unnecessary CPU and memory consumption. Version 3.0.7 fixes the issue. Some workarounds are available. Restrict request body size at the reverse proxy or web framework, rate-limit webhook endpoints, and/or reject oversized requests before JSON parsing.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-70646?

3 open source packages ship an affected version, including aiosend.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiosend` | PyPI | All versions | 3.0.7 |
| `aiosend` | PyPI | All versions | 3.0.7 |
| `aiosend` | PyPI | All versions | 3.0.7 |

## How do I fix CVE-2026-70646?

Upgrade aiosend to 3.0.7 or later.

## Is CVE-2026-70646 being exploited?

There is no known exploitation of CVE-2026-70646 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70646 and fix it if it is affected.

What it is: CVE-2026-70646 is a high-severity denial of service vulnerability in vovchic17 aiosend, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-70646 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiosend (PyPI): affected all versions; fixed in 3.0.7
- aiosend (PyPI): affected all versions; fixed in 3.0.7
- aiosend (PyPI): affected all versions; fixed in 3.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70646/ (Markdown: https://insights.sbomify.com/CVE-2026-70646/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70646
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70646
- OSV: https://osv.dev/vulnerability/CVE-2026-70646

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70646/
Summaries are generated and may contain mistakes; the official description above is the record.
