# CVE-2026-70651: libvips: Possible integer overflow when reading multi-page TIFF images via ImageMagick

> An attacker can cause a denial of service via heap buffer over-read in libvips when processing crafted multi-page TIFFs using the ImageMagick fallback path.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-70651, GHSA-7p29-wg2h-36q4, UBUNTU-CVE-2026-70651

## What is CVE-2026-70651?

CVE-2026-70651 is a medium-severity vulnerability in libvips, published on 20 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, libvips built without libtiff support but with ImageMagick support can overflow the combined frame height while loading a crafted multi-page TIFF through VipsForeignLoadMagick. The vulnerable calculations in libvips/foreign/magick6load.c and libvips/foreign/magick7load.c multiply the per-page Ysize by n_frames without a checked bound, which can cause a heap buffer over-read and process crash. Most package-manager builds include libtiff and do not use this affected fallback path. This issue is fixed in version 8.18.3.

Weakness: CWE-680 (Integer Overflow to Buffer Overflow)

## Which versions are affected by CVE-2026-70651?


## How do I fix CVE-2026-70651?

Upgrade to a fixed version.

## Is CVE-2026-70651 being exploited?

There is no known exploitation of CVE-2026-70651 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70651 and fix it if it is affected.

What it is: CVE-2026-70651 is a medium-severity vulnerability in libvips, published on 20 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-70651 in the wild and no public exploit code.

Affected product: libvips. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70651/ (Markdown: https://insights.sbomify.com/CVE-2026-70651/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70651
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70651
- OSV: https://osv.dev/vulnerability/CVE-2026-70651

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70651/
Summaries are generated and may contain mistakes; the official description above is the record.
