# CVE-2026-70652: libvips: Possible heap-based buffer read overflow when resizing and re-encoding a JPEG with gain map

> Attackers can trigger a heap buffer over-read in libvips when resizing JPEGs with gain maps, potentially disclosing memory or crashing the application.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-70652, GHSA-h27h-jf9v-m8rg, UBUNTU-CVE-2026-70652

## What is CVE-2026-70652?

CVE-2026-70652 is a low-severity vulnerability in libvips, published on 20 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, libvips built with libultrahdr support can incorrectly size an output buffer in libvips/foreign/uhdrsave.c within vips_foreign_save_uhdr_set_raw_hdr when a pipeline enlarges an incoming JPEG to a very large output before encoding a gain map through VipsForeignSaveUhdr. The undersized allocation can cause a heap buffer over-read that may disclose adjacent data or crash the process. This issue is fixed in version 8.18.3.

Weakness: CWE-126 (Buffer Over-read)

## Which versions are affected by CVE-2026-70652?


## How do I fix CVE-2026-70652?

Upgrade to a fixed version.

## Is CVE-2026-70652 being exploited?

There is no known exploitation of CVE-2026-70652 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70652 and fix it if it is affected.

What it is: CVE-2026-70652 is a low-severity vulnerability in libvips, published on 20 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-70652 in the wild and no public exploit code.

Affected product: libvips. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70652/ (Markdown: https://insights.sbomify.com/CVE-2026-70652/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70652
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70652
- OSV: https://osv.dev/vulnerability/CVE-2026-70652

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70652/
Summaries are generated and may contain mistakes; the official description above is the record.
