{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-70654 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-70654 is a medium-severity memory corruption vulnerability in libvips, published on 20 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-70654 and fix it if it is affected.\n\nWhat it is: CVE-2026-70654 is a medium-severity memory corruption vulnerability in libvips, published on 20 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-70654 in the wild and no public exploit code.\n\nAffected product: libvips. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-70654/ (Markdown: https://insights.sbomify.com/CVE-2026-70654/index.md)","id":"CVE-2026-70654","markdown":"https://insights.sbomify.com/CVE-2026-70654/index.md","name":"CVE-2026-70654","record":{"aliases":["DEBIAN-CVE-2026-70654","GHSA-rjmm-3qch-m9rg","UBUNTU-CVE-2026-70654"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Image processing library","requires_auth":"low_privilege","summary":"A heap buffer overflow in libvips allows attackers to cause memory corruption or crashes when processing crafted PPM images via custom sources.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, applications that define unusual custom libvips sources and use them to process untrusted uncompressed PPM images can trigger a max/min error in vips_source_read_to_memory in libvips/iofuncs/source.c. The function uses VIPS_MAX instead of VIPS_MIN when selecting the remaining read size, allowing up to 4032 bytes to be written beyond the allocated heap buffer and causing memory corruption or a process crash. This issue is fixed in version 8.18.3.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"libvips: A well-crafted PPM image processed via a custom source could lead to possible heap buffer write overflow","id":"CVE-2026-70654","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"Checkmate: Regular Expression Denial of Service (ReDoS) via User-Controlled Regex in Monitor Advanced Matching","id":"CVE-2026-70656"},"packages":[],"prev":{"headline":"libvips: Possible heap-based buffer read overflow when decoding a well-crafted RLE Radiance image","id":"CVE-2026-70653"},"products":["libvips"],"published":"2026-08-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-21","vendors":["libvips"]},"summary":"A heap buffer overflow in libvips allows attackers to cause memory corruption or crashes when processing crafted PPM images via custom sources.","url":"https://insights.sbomify.com/CVE-2026-70654/"}