# CVE-2026-70654: libvips: A well-crafted PPM image processed via a custom source could lead to possible heap buffer write overflow

> A heap buffer overflow in libvips allows attackers to cause memory corruption or crashes when processing crafted PPM images via custom sources.

- **Severity:** Medium 5.8 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-70654, GHSA-rjmm-3qch-m9rg, UBUNTU-CVE-2026-70654

## What is CVE-2026-70654?

CVE-2026-70654 is a medium-severity memory corruption vulnerability in libvips, published on 20 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, applications that define unusual custom libvips sources and use them to process untrusted uncompressed PPM images can trigger a max/min error in vips_source_read_to_memory in libvips/iofuncs/source.c. The function uses VIPS_MAX instead of VIPS_MIN when selecting the remaining read size, allowing up to 4032 bytes to be written beyond the allocated heap buffer and causing memory corruption or a process crash. This issue is fixed in version 8.18.3.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-70654?


## How do I fix CVE-2026-70654?

Upgrade to a fixed version.

## Is CVE-2026-70654 being exploited?

There is no known exploitation of CVE-2026-70654 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70654 and fix it if it is affected.

What it is: CVE-2026-70654 is a medium-severity memory corruption vulnerability in libvips, published on 20 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-70654 in the wild and no public exploit code.

Affected product: libvips. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70654/ (Markdown: https://insights.sbomify.com/CVE-2026-70654/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70654
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70654
- OSV: https://osv.dev/vulnerability/CVE-2026-70654

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70654/
Summaries are generated and may contain mistakes; the official description above is the record.
