# CVE-2026-70657: Copyparty: file/dirkey confusion

> Attackers can use a valid file key to gain read access to the containing directory when both file and directory key features are enabled.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-x5pq-m9p8-f4vx, PYSEC-2026-3660

## What is CVE-2026-70657?

CVE-2026-70657 is a medium-severity authentication bypass vulnerability in 9001 copyparty, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Copyparty is a portable file server. Prior to 1.20.17, copyparty volumes with the dk or dks directory-key flag combined with the fk or fka file-key flag can convert a valid file key into a directory key, granting read access to the containing folder. This vulnerability was only reachable if both types of keys (filekeys and dirkeys) were manually enabled in the volume flags simultaneously. This issue is fixed in version 1.20.17.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-70657?

3 open source packages ship an affected version, including copyparty.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `copyparty` | PyPI | All versions | 1.20.17 |
| `copyparty` | PyPI | All versions | 1.20.17 |
| `copyparty` | PyPI | All versions | 1.20.17 |

## How do I fix CVE-2026-70657?

Upgrade copyparty to 1.20.17 or later.

## Is CVE-2026-70657 being exploited?

There is no known exploitation of CVE-2026-70657 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70657 and fix it if it is affected.

What it is: CVE-2026-70657 is a medium-severity authentication bypass vulnerability in 9001 copyparty, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-70657 in the wild and no public exploit code.

Affected packages and fixed versions:
- copyparty (PyPI): affected all versions; fixed in 1.20.17
- copyparty (PyPI): affected all versions; fixed in 1.20.17
- copyparty (PyPI): affected all versions; fixed in 1.20.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70657/ (Markdown: https://insights.sbomify.com/CVE-2026-70657/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70657
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70657
- OSV: https://osv.dev/vulnerability/CVE-2026-70657

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70657/
Summaries are generated and may contain mistakes; the official description above is the record.
