CVE-2026-70907 Denial of service in Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition

Medium 5.3 Published Updated

Unauthenticated attackers can cause partial denial of service in Oracle Java SE and GraalVM via TLS network access.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-70907?

CVE-2026-70907 is a medium-severity denial of service vulnerability in Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: JSSE). Supported versions that are affected are Oracle Java SE: 8u501, 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2; Oracle GraalVM for JDK: 17.0.20 and 21.0.12; Oracle GraalVM Enterprise Edition: 21.3.19. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.1 Base Score 5.3 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L).

Weakness: CWE-284

Which versions are affected by CVE-2026-70907?

3 open source packages ship an affected version, including java, java-min and jre.

PackageAffectedFixed in
java BitnamiAll versions1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1
java-min BitnamiAll versions1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1
jre BitnamiAll versions1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1

How do I fix CVE-2026-70907?

Upgrade java to a fixed version for your release line: 1.8.0, 8.0.503, 11.0.32-1 or 17.0.20-1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-70907 being exploited?

There is no known exploitation of CVE-2026-70907 in the wild and no public exploit code.

Sources

Also known as BELL-CVE-2026-70907, BIT-java-2026-70907, BIT-java-min-2026-70907, BIT-jre-2026-70907, DEBIAN-CVE-2026-70907, GHSA-x2cm-pmmm-v6xc and 29 more.

Is CVE-2026-70907 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free