# CVE-2026-70907: Denial of service in Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition

> Unauthenticated attackers can cause partial denial of service in Oracle Java SE and GraalVM via TLS network access.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** BELL-CVE-2026-70907, BIT-java-2026-70907, BIT-java-min-2026-70907, BIT-jre-2026-70907, DEBIAN-CVE-2026-70907, GHSA-x2cm-pmmm-v6xc, MINI-2894-g9mw-fc4h, MINI-2ph4-p7m8-xp6p, MINI-2qgj-mrw4-4w4p, MINI-3jhp-p6cw-ccwm, MINI-42c7-m7vw-3382, MINI-4prv-xgwv-8w9f, MINI-4xgq-xq8g-959m, MINI-69fh-2rc4-86m6, MINI-7fp9-prmm-gmc8, MINI-86fj-h68w-97v2, MINI-8mxf-f793-4vf7, MINI-9j9r-wcpw-pmr4, MINI-9jfg-hf6q-v95h, MINI-9m8p-6495-ggg5, MINI-9mm4-hqrr-j8rj, MINI-frpj-43pr-x7gq, MINI-gxgw-rrp5-hw2f, MINI-hm76-w67v-r872, MINI-m6jv-q8cq-5rxv, MINI-m7h5-q6q2-h6f9, MINI-pc93-cfxr-rhx6, MINI-pxmm-hjm4-243j, MINI-rjvp-88f7-3jpf, MINI-w2f7-3846-m3g8, MINI-x5vj-8fxh-mrjm, MINI-xcjv-hwrx-gwx6, MINI-xq7f-hmgp-m6j2, MINI-xqg3-fhv5-8cr2, UBUNTU-CVE-2026-70907

## What is CVE-2026-70907?

CVE-2026-70907 is a medium-severity denial of service vulnerability in Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: JSSE).  Supported versions that are affected are Oracle Java SE: 8u501, 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2; Oracle GraalVM for JDK: 17.0.20 and  21.0.12; Oracle GraalVM Enterprise Edition: 21.3.19. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition.  Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.1 Base Score 5.3 (Availability impacts).  CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L).

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-70907?

3 open source packages ship an affected version, including java, java-min and jre.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | All versions | 1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1 |
| `java-min` | Bitnami | All versions | 1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1 |
| `jre` | Bitnami | All versions | 1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1 |

## How do I fix CVE-2026-70907?

Upgrade java to a fixed version for your release line: 1.8.0, 8.0.503, 11.0.32-1 or 17.0.20-1.

## Is CVE-2026-70907 being exploited?

There is no known exploitation of CVE-2026-70907 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-70907 and fix it if it is affected.

What it is: CVE-2026-70907 is a medium-severity denial of service vulnerability in Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-70907 in the wild and no public exploit code.

Affected packages and fixed versions:
- java (Bitnami): affected all versions; fixed in 1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1
- java-min (Bitnami): affected all versions; fixed in 1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1
- jre (Bitnami): affected all versions; fixed in 1.8.0, 8.0.503, 11.0.32-1, 17.0.20-1, 21.0.12-1, 25.0.4-1, 26.0.2-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-70907/ (Markdown: https://insights.sbomify.com/CVE-2026-70907/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-70907
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-70907
- OSV: https://osv.dev/vulnerability/CVE-2026-70907

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-70907/
Summaries are generated and may contain mistakes; the official description above is the record.
