# CVE-2026-71216: Apache SkyWalking: PagerDuty alarm hook transmits the integration routing key over cleartext HTTP

> Apache SkyWalking exposes PagerDuty integration routing keys in cleartext HTTP requests, allowing attackers to intercept sensitive credentials.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Sep 2026
- **Updated:** 8 Sep 2026
- **Also known as:** GHSA-f684-fh59-2gh3

## What is CVE-2026-71216?

CVE-2026-71216 is a medium-severity vulnerability in Apache SkyWalking, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PagerDuty alarm hook transmits the integration routing key over cleartext HTTP.

PagerDuty serves this endpoint over HTTPS and will
normally answer plain HTTP with a redirect. That does not remove the exposure.
The initial POST -- including the JSON body containing the routing key -- is
written to the socket unencrypted before any redirect response is received.
Redirection affects only whether the request is retried securely, not whether
the first copy left the host in the clear.

This issue affects Apache SkyWalking: from 9.6.0 through 11.0.0.

Users are recommended to upgrade to version 11.0.0, which fixes the issue.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2026-71216?


## How do I fix CVE-2026-71216?

No fix has been published for CVE-2026-71216 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-71216 being exploited?

There is no known exploitation of CVE-2026-71216 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71216 and fix it if it is affected.

What it is: CVE-2026-71216 is a medium-severity vulnerability in Apache SkyWalking, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-71216 in the wild and no public exploit code.

Affected product: Apache SkyWalking. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71216/ (Markdown: https://insights.sbomify.com/CVE-2026-71216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71216
- OSV: https://osv.dev/vulnerability/CVE-2026-71216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71216/
Summaries are generated and may contain mistakes; the official description above is the record.
