{"answers":{"affected":"3 open source packages ship an affected version, including lemur.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71303 exists.","fix":"Upgrade lemur to 1.9.3 or later.","what":"CVE-2026-71303 is a high-severity server-side request forgery vulnerability in Netflix lemur, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-71303 and fix it if it is affected.\n\nWhat it is: CVE-2026-71303 is a high-severity server-side request forgery vulnerability in Netflix lemur, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71303 exists.\n\nAffected packages and fixed versions:\n- lemur (PyPI): affected all versions; fixed in 1.9.3\n- lemur (PyPI): affected all versions; fixed in 1.9.3\n- lemur (PyPI): affected all versions; fixed in 1.9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-71303/ (Markdown: https://insights.sbomify.com/CVE-2026-71303/index.md)","id":"CVE-2026-71303","markdown":"https://insights.sbomify.com/CVE-2026-71303/index.md","name":"CVE-2026-71303","record":{"aliases":["GHSA-v5rc-cpwc-cfpr","PYSEC-2026-3679"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"TLS certificate management","requires_auth":"low_privilege","summary":"A non-admin user can bypass allowlist checks to set an internal ACME URL, triggering Server-Side Request Forgery to access internal services or cloud metadata.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Lemur manages TLS certificate creation. Prior to 1.9.3, _validate_acme_url enforced ACME_DIRECTORY_HOST_ALLOWLIST when an authority was created, but PUT /api/1/authorities/ passed options to lemur/authorities/service.py without applying the same check. A user holding an authority role could replace the stored acme_url with an internal service or instance-metadata URL such as 169.254.169.254. The next issuance operation loaded that value and passed it to ClientV2.get_directory, causing an outbound request from the Lemur backend. This bypassed the creation-time mitigation for CVE-2026-55166 and could expose internal services or cloud metadata. The fix revalidates acme_url whenever authority options are updated. This issue is fixed in version 1.9.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Lemur: Incomplete fix for GHSA-v2wp-frmc-5q3v -- ACME authority update endpoint allows non-admin to replace `acme_url` with internal IP, bypassing allowlist","id":"CVE-2026-71303","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Lemur: Authenticated low-privilege users can read plaintext destination credentials (SFTP password / private-key passphrase) via the destinations API","id":"CVE-2026-71307"},"packages":[{"ecosystem":"PyPI","fixed":["1.9.3"],"introduced":["0"],"last_affected":[],"package":"lemur","purl":null,"source":"GHSA-v5rc-cpwc-cfpr"},{"ecosystem":"PyPI","fixed":["1.9.3"],"introduced":["0"],"last_affected":[],"package":"lemur","purl":"pkg:pypi/lemur","source":"GHSA-v5rc-cpwc-cfpr"},{"ecosystem":"PyPI","fixed":["1.9.3"],"introduced":["0"],"last_affected":[],"package":"lemur","purl":"pkg:pypi/lemur","source":"PYSEC-2026-3679"}],"prev":{"headline":"Toptech TMS7 and TopHAT Session Fixation","id":"CVE-2026-71302"},"products":["lemur"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-18","vendors":["Netflix"]},"summary":"A non-admin user can bypass allowlist checks to set an internal ACME URL, triggering Server-Side Request Forgery to access internal services or cloud metadata.","url":"https://insights.sbomify.com/CVE-2026-71303/"}