CVE-2026-71308 Lemur: Unchecked `replaces[]` lets any user silence notifications and hijack auto-rotation for arbitrary certificates

High 8.1 Published Updated

Authenticated users can hijack certificate rotation and suppress notifications for arbitrary certificates due to missing permission checks on replacement objects.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-71308?

CVE-2026-71308 is a high-severity missing authorization vulnerability in Netflix lemur, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Lemur manages TLS certificate creation. From 0.5.0 until 1.9.3, certificate create, upload, and edit requests accepted replaces[] or replacements identifiers that AssociatedCertificateSchema resolved with fetch_objects without a CertificatePermission check. Assigning those objects to Certificate.replaces invoked an append listener that disabled the victim certificate notifications and marked it as replaced. The victim was then excluded from get_all_pending_reissue, and certificate_rotate could deploy the attacker certificate to endpoints serving the victim. An authenticated non-read-only user could target certificates for which the user had no ownership or role, suppress lifecycle automation, and cause fleet-wide TLS disruption or unauthorized substitution. The fix authorizes every referenced replacement certificate before mutation. This issue is fixed in version 1.9.3.

Weakness: CWE-862, CWE-639

Which versions are affected by CVE-2026-71308?

3 open source packages ship an affected version, including lemur.

PackageAffectedFixed in
lemur PyPIFrom 0.5.01.9.3
lemur PyPIFrom 0.5.01.9.3
lemur PyPIFrom 0.5.01.9.3

How do I fix CVE-2026-71308?

Upgrade lemur to 1.9.3 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-71308 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71308 exists.

Sources

Also known as GHSA-cfh6-pv5c-38jv, PYSEC-2026-3675.

Is CVE-2026-71308 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free