# CVE-2026-71316: Nuxt runtime payload cache discloses another user's SSR data across users and to unauthenticated clients

> Attackers can access other users' server-side rendering data via cached payload endpoints, exposing sensitive information to unauthenticated clients.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2026
- **Updated:** 6 Aug 2026
- **Also known as:** GHSA-wm8w-6qjm-cv43

## What is CVE-2026-71316?

CVE-2026-71316 is a high-severity vulnerability in nuxt, published on 5 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nuxt is an open-source web development framework for Vue.js. From 4.4.0 until 4.5.1, runtime cache:nuxt:payload entries for /<page>/_payload.json can be returned before route middleware and page guards because import.meta.prerender is not enforced, disclosing another user's SSR data. This issue is fixed in 4.5.1.

Weakness: CWE-862 (Missing Authorization), CWE-524 (Use of Cache Containing Sensitive Information)

## Which versions are affected by CVE-2026-71316?

2 open source packages ship an affected version, including nuxt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nuxt` | npm | From 4.4.0 | 4.5.1 |
| `nuxt` | npm | From 4.4.0 | 4.5.1 |

## How do I fix CVE-2026-71316?

Upgrade nuxt to 4.5.1 or later.

## Is CVE-2026-71316 being exploited?

There is no known exploitation of CVE-2026-71316 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71316 and fix it if it is affected.

What it is: CVE-2026-71316 is a high-severity vulnerability in nuxt, published on 5 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-71316 in the wild and no public exploit code.

Affected packages and fixed versions:
- nuxt (npm): affected from 4.4.0; fixed in 4.5.1
- nuxt (npm): affected from 4.4.0; fixed in 4.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71316/ (Markdown: https://insights.sbomify.com/CVE-2026-71316/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71316
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71316
- OSV: https://osv.dev/vulnerability/CVE-2026-71316

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71316/
Summaries are generated and may contain mistakes; the official description above is the record.
