# CVE-2026-71317: Lemur: Sub-CA creation never checks `AuthorityPermission` on the parent authority

> Authenticated users can create unauthorized sub-CAs under internal roots when ADMIN_ONLY_AUTHORITY_CREATION is disabled, enabling trusted certificate issuance and potential key misuse.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-g7p5-89mh-248h, PYSEC-2026-3677

## What is CVE-2026-71317?

CVE-2026-71317 is a medium-severity missing authorization vulnerability in Netflix lemur, published on 18 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Lemur manages TLS certificate creation. Prior to 1.9.3, POST /api/1/authorities with type=subca did not require AuthorityPermission on the parent authority when ADMIN_ONLY_AUTHORITY_CREATION was false. AssociatedAuthoritySchema resolved the caller-supplied parent and passed it through authority creation to cryptography-issuer, which used the parent authority_certificate.private_key to sign a new intermediate. Any authenticated non-read-only user in that supported configuration could chain a sub-CA to an internal root for which the user held no role. The resulting intermediate could issue trusted certificates and its private key could be used outside Lemur, bypassing normal issuance controls. The fix checks AuthorityPermission on every supplied parent before invoking the issuer. This issue is fixed in version 1.9.3.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-71317?

3 open source packages ship an affected version, including lemur.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lemur` | PyPI | All versions | 1.9.3 |
| `lemur` | PyPI | All versions | 1.9.3 |
| `lemur` | PyPI | All versions | 1.9.3 |

## How do I fix CVE-2026-71317?

Upgrade lemur to 1.9.3 or later.

## Is CVE-2026-71317 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71317 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71317 and fix it if it is affected.

What it is: CVE-2026-71317 is a medium-severity missing authorization vulnerability in Netflix lemur, published on 18 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71317 exists.

Affected packages and fixed versions:
- lemur (PyPI): affected all versions; fixed in 1.9.3
- lemur (PyPI): affected all versions; fixed in 1.9.3
- lemur (PyPI): affected all versions; fixed in 1.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71317/ (Markdown: https://insights.sbomify.com/CVE-2026-71317/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71317
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71317
- OSV: https://osv.dev/vulnerability/CVE-2026-71317

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71317/
Summaries are generated and may contain mistakes; the official description above is the record.
