# CVE-2026-71322: Lemur: Missing authorization check on POST /certificates/<id>/export for plugins with requires_key = False

> Attackers can bypass ownership checks to export certificates via plugins that do not require private keys, potentially exposing public certificate data and corrupting audit logs.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-4h97-p9wq-chqj, PYSEC-2026-3673

## What is CVE-2026-71322?

CVE-2026-71322 is a medium-severity missing authorization vulnerability in Netflix lemur, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Lemur manages TLS certificate creation. Prior to 1.9.3, CertificateExport placed its CertificatePermission ownership check inside the plugin.requires_key branch for POST /api/1/certificates//export. A plugin declaring requires_key false bypassed that check, and the handler still passed cert.private_key as an argument and recorded a key_view audit event. The bundled JavaTruststoreExportPlugin ignored the key, so the immediate exposure was limited to public certificate material and misleading audit entries, but a future plugin could have consumed the supplied key. The fix passes no private key to plugins that do not require one and confines ownership checks and key_view logging to actual private-key exports. This issue is fixed in version 1.9.3.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-71322?

3 open source packages ship an affected version, including lemur.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lemur` | PyPI | All versions | 1.9.3 |
| `lemur` | PyPI | All versions | 1.9.3 |
| `lemur` | PyPI | All versions | 1.9.3 |

## How do I fix CVE-2026-71322?

Upgrade lemur to 1.9.3 or later.

## Is CVE-2026-71322 being exploited?

There is no known exploitation of CVE-2026-71322 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71322 and fix it if it is affected.

What it is: CVE-2026-71322 is a medium-severity missing authorization vulnerability in Netflix lemur, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-71322 in the wild and no public exploit code.

Affected packages and fixed versions:
- lemur (PyPI): affected all versions; fixed in 1.9.3
- lemur (PyPI): affected all versions; fixed in 1.9.3
- lemur (PyPI): affected all versions; fixed in 1.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71322/ (Markdown: https://insights.sbomify.com/CVE-2026-71322/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71322
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71322
- OSV: https://osv.dev/vulnerability/CVE-2026-71322

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71322/
Summaries are generated and may contain mistakes; the official description above is the record.
