CVE-2026-7141 vLLM KV Block kv_cache_interface.py has_mamba_layers uninitialized resource
Uninitialized resource in vLLM KV block handler may cause undefined behavior, though disputed as benign variance.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-7141?
CVE-2026-7141 is a medium-severity vulnerability in Vllm Vllm, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A vulnerability was found in vLLM up to 0.19.0. The affected element is the function has_mamba_layers of the file vllm/v1/kv_cache_interface.py of the component KV Block Handler. Performing a manipulation results in uninitialized resource. It is possible to initiate the attack remotely. The attack is considered to have high complexity. The exploitability is described as difficult. The exploit has been made public and could be used. The existence of this vulnerability is still disputed at present. The proposed patch did not fix the issue. A 3rd party explains: "The divergence could be explained by a benign and expected vLLM behavior where vLLM server could group concurrent requests together resulting in different input shapes based on varying request arrival time. The differences in grouped input shapes could call different kernels with could produce difference results due to rounding and differences in order of operations. There is an environment variable VLLM_BATCH_INVARIANT=1 for users that desire to have deterministic output with temperature 0.0."
Weakness: CWE-908
Which versions are affected by CVE-2026-7141?
3 open source packages ship an affected version, including vllm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
vllm PyPI | All versions | 0.19.1 |
vllm PyPI | All versions | 0.19.1 |
vllm PyPI | All versions | 0.19.1 |
Products include Vllm Vllm.
How do I fix CVE-2026-7141?
Upgrade vllm to 0.19.1 or later.
Is CVE-2026-7141 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7141 exists.
Other vulnerabilities in Vllm Vllm
- CVE-2025-32444 vLLM Vulnerable to Remote Code Execution via Mooncake Integration
- CVE-2026-22778 vLLM leaks a heap address when PIL throws an error
- CVE-2025-47277 vLLM Allows Remote Code Execution via PyNcclPipe Communication Service
- CVE-2024-11041 Remote Code Execution in vllm-project/vllm
- CVE-2026-48746 vLLM: OpenAI auth bypass
Sources
Also known as GHSA-x368-4g9h-fvv4, PYSEC-2026-2306.