# CVE-2026-71415: Kirby: File upload permissions are not checked during processing of chunk data

> Authenticated users can bypass upload authorization checks to fill temporary storage, causing denial of service for other users.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2026
- **Updated:** 3 Sep 2026
- **Also known as:** GHSA-67mx-6wf2-92xp

## What is CVE-2026-71415?

CVE-2026-71415 is a high-severity missing authorization vulnerability in getkirby kirby, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kirby is an open-source content management system. From 5.0.0 until 5.5.2, Kirby's REST API chunk upload handler in src/Api/Upload.php did not run the relevant upload authorization preflight in Kirby\Api\Upload::process() before Kirby\Api\Upload::processChunk() persisted chunk data. An authenticated user with the access.panel permission enabled but with files.create, files.replace, and user/users.update permissions disabled could submit requests with an Upload-Length header and leave unfinished chunks in site/cache/.uploads for 24 hours. Repeating this process could consume attacker-controlled temporary storage, prevent other users from uploading files, or prevent site logic from storing data, although final permission checks still prevented unauthorized files from reaching the content or site/accounts directories. This issue is fixed in version 5.5.2.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-71415?

2 open source packages ship an affected version, including getkirby/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.5.2 |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.5.2 |

## How do I fix CVE-2026-71415?

Upgrade getkirby/cms to 5.5.2 or later.

## Is CVE-2026-71415 being exploited?

There is no known exploitation of CVE-2026-71415 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71415 and fix it if it is affected.

What it is: CVE-2026-71415 is a high-severity missing authorization vulnerability in getkirby kirby, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-71415 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.5.2
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71415/ (Markdown: https://insights.sbomify.com/CVE-2026-71415/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71415
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71415
- OSV: https://osv.dev/vulnerability/CVE-2026-71415

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71415/
Summaries are generated and may contain mistakes; the official description above is the record.
