# CVE-2026-71416: Headroom vulnerable to Cross-Site WebSocket Hijacking (CSWSH)

> Attackers can hijack WebSocket sessions to perform unauthorized LLM requests and access API keys due to missing Origin header validation.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Sep 2026
- **Updated:** 11 Sep 2026
- **Also known as:** GHSA-h46j-26q3-rggf, PYSEC-2026-4220

## What is CVE-2026-71416?

CVE-2026-71416 is a high-severity vulnerability in headroomlabs-ai headroom, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Headroom compresses data before the data reaches a large language model. Prior to version 0.35.0, the Headroom WebSocket server does not validate the `Origin` header of incoming client WebSocket requests before forwarding the request to the upstream server, allowing malicious WebSocket clients to perform arbitrary LLM requests without authentication. This can be exploited by a malicious WebSocket client executed in a traditional or headless browser such as lightpanda, if the browser has access to the Headroom proxy and the OpenAI API key is stored in the `OPENAI_API_KEY` environment variable. Version 0.35.0 fixes the issue.

Weakness: CWE-287 (Improper Authentication), CWE-1385 (Missing Origin Validation in WebSockets)

## Which versions are affected by CVE-2026-71416?

3 open source packages ship an affected version, including headroom-ai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `headroom-ai` | PyPI | All versions | 0.35.0 |
| `headroom-ai` | PyPI | All versions | 0.35.0 |
| `headroom-ai` | PyPI | All versions | 0.35.0 |

## How do I fix CVE-2026-71416?

Upgrade headroom-ai to 0.35.0 or later.

## Is CVE-2026-71416 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71416 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71416 and fix it if it is affected.

What it is: CVE-2026-71416 is a high-severity vulnerability in headroomlabs-ai headroom, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71416 exists.

Affected packages and fixed versions:
- headroom-ai (PyPI): affected all versions; fixed in 0.35.0
- headroom-ai (PyPI): affected all versions; fixed in 0.35.0
- headroom-ai (PyPI): affected all versions; fixed in 0.35.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71416/ (Markdown: https://insights.sbomify.com/CVE-2026-71416/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71416
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71416
- OSV: https://osv.dev/vulnerability/CVE-2026-71416

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71416/
Summaries are generated and may contain mistakes; the official description above is the record.
