# CVE-2026-71417: Lemur: Any user can revoke arbitrary certificates at the CA by uploading a duplicate record and revoking it

> An attacker can revoke arbitrary TLS certificates by uploading duplicates, causing fleet-wide denial of service in Lemur.

- **Severity:** High 7.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-pxmc-2ffp-8j67, PYSEC-2026-3678

## What is CVE-2026-71417?

CVE-2026-71417 is a high-severity missing authorization vulnerability in Netflix lemur, published on 18 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Lemur manages TLS certificate creation. Prior to 1.9.3, POST /api/1/certificates/upload allowed a non-read-only user to create a duplicate row using another certificate body, authority_id, serial, or external_id without requiring permission on the underlying authority. PUT /api/1/certificates//revoke authorized the caller against only the selected Lemur row, so the creator of the duplicate bypassed CertificatePermission. The duplicate had no cert.endpoints, which also bypassed the safeguard that prevents revocation of deployed certificates. Issuer plugins then revoked the real CA-side certificate using certificate.body or external_id under the stored authority credentials. An attacker could therefore revoke arbitrary managed certificates and cause fleet-wide TLS denial of service. The fix rejects duplicate authority_id and serial identities, requires authority access on upload, and checks every matching row during revocation. This issue is fixed in version 1.9.3.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-71417?

3 open source packages ship an affected version, including lemur.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lemur` | PyPI | All versions | 1.9.3 |
| `lemur` | PyPI | All versions | 1.9.3 |
| `lemur` | PyPI | All versions | 1.9.3 |

## How do I fix CVE-2026-71417?

Upgrade lemur to 1.9.3 or later.

## Is CVE-2026-71417 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71417 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71417 and fix it if it is affected.

What it is: CVE-2026-71417 is a high-severity missing authorization vulnerability in Netflix lemur, published on 18 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71417 exists.

Affected packages and fixed versions:
- lemur (PyPI): affected all versions; fixed in 1.9.3
- lemur (PyPI): affected all versions; fixed in 1.9.3
- lemur (PyPI): affected all versions; fixed in 1.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71417/ (Markdown: https://insights.sbomify.com/CVE-2026-71417/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71417
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71417
- OSV: https://osv.dev/vulnerability/CVE-2026-71417

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71417/
Summaries are generated and may contain mistakes; the official description above is the record.
