{"answers":{"affected":"3 open source packages ship an affected version, including wooey.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7142 exists.","fix":"Upgrade wooey to 0.13.3rc1 or later.","what":"CVE-2026-7142 is a medium-severity missing authorization vulnerability in Wooey, published on 27 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-7142 and fix it if it is affected.\n\nWhat it is: CVE-2026-7142 is a medium-severity missing authorization vulnerability in Wooey, published on 27 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7142 exists.\n\nAffected packages and fixed versions:\n- wooey (PyPI): affected all versions; fixed in 0.13.3rc1\n- wooey (PyPI): affected all versions; fixed in 0.13.3rc1\n- wooey (PyPI): affected all versions; fixed in 0.13.3rc1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-7142/ (Markdown: https://insights.sbomify.com/CVE-2026-7142/index.md)","id":"CVE-2026-7142","markdown":"https://insights.sbomify.com/CVE-2026-7142/index.md","name":"CVE-2026-7142","record":{"aliases":["GHSA-w65c-cmxj-qrhm","PYSEC-2026-3427"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Wooey web application","requires_auth":"low_privilege","summary":"Remote attackers can bypass authorization in the Wooey API to add or update scripts, potentially modifying application behavior or data.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"},{"id":"CWE-266","name":"Incorrect Privilege Assignment"}],"description":"A vulnerability was determined in Wooey up to 0.13.2. The impacted element is the function add_or_update_script of the file wooey/api/scripts.py of the component API Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 0.13.3rc1 and 0.14.0 is sufficient to resolve this issue. This patch is called f7846fc0c323da8325422cab32623491757f1b88. The affected component should be upgraded.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Wooey API Endpoint scripts.py add_or_update_script improper authorization","id":"CVE-2026-7142","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":3,"n_references":8,"next":{"headline":"1000 Projects Portfolio Management System MCA block_status.php sql injection","id":"CVE-2026-7143"},"packages":[{"ecosystem":"PyPI","fixed":["0.13.3rc1"],"introduced":["0"],"last_affected":[],"package":"wooey","purl":null,"source":"GHSA-w65c-cmxj-qrhm"},{"ecosystem":"PyPI","fixed":["0.13.3rc1"],"introduced":["0"],"last_affected":[],"package":"wooey","purl":"pkg:pypi/wooey","source":"GHSA-w65c-cmxj-qrhm"},{"ecosystem":"PyPI","fixed":["0.13.3rc1"],"introduced":["0"],"last_affected":[],"package":"wooey","purl":"pkg:pypi/wooey","source":"PYSEC-2026-3427"}],"prev":{"headline":"vLLM KV Block kv_cache_interface.py has_mamba_layers uninitialized resource","id":"CVE-2026-7141"},"products":["Wooey"],"published":"2026-04-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-27","vendors":["n/a"]},"summary":"Remote attackers can bypass authorization in the Wooey API to add or update scripts, potentially modifying application behavior or data.","url":"https://insights.sbomify.com/CVE-2026-7142/"}