# CVE-2026-7142: Wooey API Endpoint scripts.py add_or_update_script improper authorization

> Remote attackers can bypass authorization in the Wooey API to add or update scripts, potentially modifying application behavior or data.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2026
- **Updated:** 27 Apr 2026
- **Also known as:** GHSA-w65c-cmxj-qrhm, PYSEC-2026-3427

## What is CVE-2026-7142?

CVE-2026-7142 is a medium-severity missing authorization vulnerability in Wooey, published on 27 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was determined in Wooey up to 0.13.2. The impacted element is the function add_or_update_script of the file wooey/api/scripts.py of the component API Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 0.13.3rc1 and 0.14.0 is sufficient to resolve this issue. This patch is called f7846fc0c323da8325422cab32623491757f1b88. The affected component should be upgraded.

Weakness: CWE-285 (Improper Authorization), CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2026-7142?

3 open source packages ship an affected version, including wooey.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wooey` | PyPI | All versions | 0.13.3rc1 |
| `wooey` | PyPI | All versions | 0.13.3rc1 |
| `wooey` | PyPI | All versions | 0.13.3rc1 |

## How do I fix CVE-2026-7142?

Upgrade wooey to 0.13.3rc1 or later.

## Is CVE-2026-7142 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7142 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7142 and fix it if it is affected.

What it is: CVE-2026-7142 is a medium-severity missing authorization vulnerability in Wooey, published on 27 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7142 exists.

Affected packages and fixed versions:
- wooey (PyPI): affected all versions; fixed in 0.13.3rc1
- wooey (PyPI): affected all versions; fixed in 0.13.3rc1
- wooey (PyPI): affected all versions; fixed in 0.13.3rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7142/ (Markdown: https://insights.sbomify.com/CVE-2026-7142/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7142
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7142
- OSV: https://osv.dev/vulnerability/CVE-2026-7142

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7142/
Summaries are generated and may contain mistakes; the official description above is the record.
