CVE-2026-71424 Onyx: Cross-user OAuth-token leak via /api/mcp/servers* for per-user MCP servers
Attackers can steal other users' OAuth tokens via exposed API endpoints, potentially leading to account takeover in the Onyx AI platform.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-71424?
CVE-2026-71424 is a critical vulnerability in onyx-dot-app onyx, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Onyx is an open-source AI platform. Prior to 3.1.10, 3.2.14, and 4.0.0, Onyx's GET /api/mcp/servers and GET /api/mcp/servers/persona/{persona_id} endpoints expose another user's OAuth Authorization header because OnyxTokenStorage.set_tokens and OnyxTokenStorage.set_client_info in backend/onyx/server/features/mcp/api.py copy per-user tokens into a shared admin MCPConnectionConfig row and _db_mcp_server_to_api_mcp_server returns that row through auth_template.headers to any BASIC_ACCESS user. This issue is fixed in versions 3.1.10, 3.2.14, and 4.0.0.
Which versions are affected by CVE-2026-71424?
How do I fix CVE-2026-71424?
No fix has been published for CVE-2026-71424 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-71424 being exploited?
There is no known exploitation of CVE-2026-71424 in the wild and no public exploit code.
Sources
Also known as GHSA-q62f-rv3h-f822.