# CVE-2026-71424: Onyx: Cross-user OAuth-token leak via /api/mcp/servers* for per-user MCP servers

> Attackers can steal other users' OAuth tokens via exposed API endpoints, potentially leading to account takeover in the Onyx AI platform.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-q62f-rv3h-f822

## What is CVE-2026-71424?

CVE-2026-71424 is a critical vulnerability in onyx-dot-app onyx, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Onyx is an open-source AI platform. Prior to 3.1.10, 3.2.14, and 4.0.0, Onyx's GET /api/mcp/servers and GET /api/mcp/servers/persona/{persona_id} endpoints expose another user's OAuth Authorization header because OnyxTokenStorage.set_tokens and OnyxTokenStorage.set_client_info in backend/onyx/server/features/mcp/api.py copy per-user tokens into a shared admin MCPConnectionConfig row and _db_mcp_server_to_api_mcp_server returns that row through auth_template.headers to any BASIC_ACCESS user. This issue is fixed in versions 3.1.10, 3.2.14, and 4.0.0.

Weakness: CWE-863 (Incorrect Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-71424?


## How do I fix CVE-2026-71424?

No fix has been published for CVE-2026-71424 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-71424 being exploited?

There is no known exploitation of CVE-2026-71424 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71424 and fix it if it is affected.

What it is: CVE-2026-71424 is a critical vulnerability in onyx-dot-app onyx, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-71424 in the wild and no public exploit code.

Affected product: onyx-dot-app onyx. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71424/ (Markdown: https://insights.sbomify.com/CVE-2026-71424/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71424
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71424
- OSV: https://osv.dev/vulnerability/CVE-2026-71424

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71424/
Summaries are generated and may contain mistakes; the official description above is the record.
