# CVE-2026-71430: node-re2: String.prototype.replace(re2, template) aborts the Node process (uncatchable ToLocalChecked on empty MaybeLocal) when the result exceeds V8's max string length

> An attacker can crash the Node.js process by triggering a regex replacement that exceeds V8's string length limit, causing an uncatchable abort.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 7 Aug 2026
- **Also known as:** CLEANSTART-2026-ID87281, DEBIAN-CVE-2026-71430, GHSA-8hcv-x26h-mcgp, MINI-9fpv-fqh3-c3mq, UBUNTU-CVE-2026-71430

## What is CVE-2026-71430?

CVE-2026-71430 is a medium-severity denial of service vulnerability in uhop node-re2, published on 6 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

node-re2 provides RE2 regular expression bindings for Node.js. Prior to version 1.25.1, the WrappedRE2::Replace function built its replacement result and passed it to V8 using ToLocalChecked without checking for the empty MaybeLocal that V8 returns when the resulting string or buffer exceeds V8's maximum string length. When a global replace uses an output amplifying replacement template, the result can grow quadratically with the input size, and once the result exceeds V8's maximum string length, the unchecked ToLocalChecked call causes a fatal, uncatchable process abort instead of a catchable exception. This issue is fixed in version 1.25.1.

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2026-71430?

2 open source packages ship an affected version, including re2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `re2` | npm | All versions | 1.25.1 |
| `re2` | npm | All versions | 1.25.1 |

## How do I fix CVE-2026-71430?

Upgrade re2 to 1.25.1 or later.

## Is CVE-2026-71430 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71430 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71430 and fix it if it is affected.

What it is: CVE-2026-71430 is a medium-severity denial of service vulnerability in uhop node-re2, published on 6 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71430 exists.

Affected packages and fixed versions:
- re2 (npm): affected all versions; fixed in 1.25.1
- re2 (npm): affected all versions; fixed in 1.25.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71430/ (Markdown: https://insights.sbomify.com/CVE-2026-71430/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71430
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71430
- OSV: https://osv.dev/vulnerability/CVE-2026-71430

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71430/
Summaries are generated and may contain mistakes; the official description above is the record.
