# CVE-2026-71433: LangGraph: Namespace prefix matching crosses segment boundaries in Postgres and SQLite stores

> An authenticated attacker can retrieve data from other tenants or users due to flawed namespace prefix matching in LangGraph checkpoint stores.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 7 Aug 2026
- **Also known as:** GHSA-47pj-3jcm-6whg, PYSEC-2026-3635, PYSEC-2026-3636

## What is CVE-2026-71433?

CVE-2026-71433 is a medium-severity missing authorization vulnerability in langchain-ai langgraph, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LangGraph Checkpoint Postgres and SQLite Checkpoint are the Postgres and SQLite implementations of LangGraph's checkpoint saver. Prior to 3.1.1, the langgraph-checkpoint-postgres and langgraph-checkpoint-sqlite packages persisted hierarchical namespaces as a dot joined string and scoped reads by matching that string as a simple prefix pattern, so a read scoped to one namespace could also match a sibling namespace whose flattened form shares the same leading characters, or a namespace label containing unescaped pattern metacharacters, allowing an authenticated caller to retrieve stored items belonging to another tenant or user through an ordinary scoped search or list namespaces call, with no crafted input required. This issue is fixed in versions 3.1.1 of langgraph-checkpoint-postgres and langgraph-checkpoint-sqlite.

Weakness: CWE-863 (Incorrect Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-71433?

6 open source packages ship an affected version, including langgraph-checkpoint-postgres and langgraph-checkpoint-sqlite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langgraph-checkpoint-postgres` | PyPI | All versions | 3.1.1 |
| `langgraph-checkpoint-postgres` | PyPI | All versions | 3.1.1 |
| `langgraph-checkpoint-postgres` | PyPI | All versions | 3.1.1 |
| `langgraph-checkpoint-sqlite` | PyPI | All versions | 3.1.1 |
| `langgraph-checkpoint-sqlite` | PyPI | All versions | 3.1.1 |
| `langgraph-checkpoint-sqlite` | PyPI | All versions | 3.1.1 |

## How do I fix CVE-2026-71433?

Upgrade langgraph-checkpoint-postgres to 3.1.1 or later.

## Is CVE-2026-71433 being exploited?

There is no known exploitation of CVE-2026-71433 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71433 and fix it if it is affected.

What it is: CVE-2026-71433 is a medium-severity missing authorization vulnerability in langchain-ai langgraph, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-71433 in the wild and no public exploit code.

Affected packages and fixed versions:
- langgraph-checkpoint-postgres (PyPI): affected all versions; fixed in 3.1.1
- langgraph-checkpoint-postgres (PyPI): affected all versions; fixed in 3.1.1
- langgraph-checkpoint-postgres (PyPI): affected all versions; fixed in 3.1.1
- langgraph-checkpoint-sqlite (PyPI): affected all versions; fixed in 3.1.1
- langgraph-checkpoint-sqlite (PyPI): affected all versions; fixed in 3.1.1
- langgraph-checkpoint-sqlite (PyPI): affected all versions; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71433/ (Markdown: https://insights.sbomify.com/CVE-2026-71433/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71433
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71433
- OSV: https://osv.dev/vulnerability/CVE-2026-71433

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71433/
Summaries are generated and may contain mistakes; the official description above is the record.
