# CVE-2026-71435: Statamic: Stored Cross-Site Scripting in Automagic Form Notification Email Template

> An unauthenticated attacker can inject malicious HTML into form notification emails, potentially leading to code execution or account takeover for recipients.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 8 Aug 2026
- **Also known as:** GHSA-vx89-p3j7-8xqc

## What is CVE-2026-71435?

CVE-2026-71435 is a medium-severity cross-site scripting vulnerability in statamic cms, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Statamic is a Laravel and Git powered content management system (CMS). Prior to 5.74.3 and 6.24.2, the default ("automagic") form notification email rendered user-submitted values without escaping, allowing an unauthenticated form submitter to inject HTML into the notification emails sent to the configured recipients. This issue is fixed in versions 5.74.3 and 6.24.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-71435?

4 open source packages ship an affected version, including statamic/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `statamic/cms` | Packagist | All versions | 5.74.3 |
| `statamic/cms` | Packagist | All versions | 5.74.3 |
| `statamic/cms` | Packagist | From 6.0.0 | 6.24.2 |
| `statamic/cms` | Packagist | From 6.0.0 | 6.24.2 |

## How do I fix CVE-2026-71435?

Upgrade statamic/cms to a fixed version for your release line: 5.74.3 or 6.24.2.

## Is CVE-2026-71435 being exploited?

There is no known exploitation of CVE-2026-71435 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71435 and fix it if it is affected.

What it is: CVE-2026-71435 is a medium-severity cross-site scripting vulnerability in statamic cms, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-71435 in the wild and no public exploit code.

Affected packages and fixed versions:
- statamic/cms (Packagist): affected all versions; fixed in 5.74.3
- statamic/cms (Packagist): affected all versions; fixed in 5.74.3
- statamic/cms (Packagist): affected from 6.0.0; fixed in 6.24.2
- statamic/cms (Packagist): affected from 6.0.0; fixed in 6.24.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71435/ (Markdown: https://insights.sbomify.com/CVE-2026-71435/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71435
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71435
- OSV: https://osv.dev/vulnerability/CVE-2026-71435

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71435/
Summaries are generated and may contain mistakes; the official description above is the record.
