# CVE-2026-71437: Mermaid Architecture diagrams are vulnerable to prototype pollution

> Attackers can pollute Object.prototype via malicious diagram text, potentially compromising the embedding application's behavior.

- **Severity:** Medium 6.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 7 Aug 2026
- **Also known as:** CLEANSTART-2026-VN44005, DEBIAN-CVE-2026-71437, GHSA-3rrr-jr9j-h3q3, MINI-2jvp-98h4-crph, MINI-q5x3-44hg-hpmf, UBUNTU-CVE-2026-71437

## What is CVE-2026-71437?

CVE-2026-71437 is a medium-severity vulnerability in mermaid-js mermaid, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. From version 11.5.0 until 11.16.1, Mermaid Architecture Diagrams are vulnerable to prototype pollution when a diagram defines a group with an id of __proto__. Because the group id is used directly as an object property key without validation, an attacker who can supply diagram text can pollute Object.prototype, potentially affecting the behavior of the embedding application. This issue is fixed in version 11.16.1.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-71437?

2 open source packages ship an affected version, including mermaid.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mermaid` | npm | From 11.5.0 | 11.16.1 |
| `mermaid` | npm | From 11.5.0 | 11.16.1 |

## How do I fix CVE-2026-71437?

Upgrade mermaid to 11.16.1 or later.

## Is CVE-2026-71437 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71437 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71437 and fix it if it is affected.

What it is: CVE-2026-71437 is a medium-severity vulnerability in mermaid-js mermaid, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71437 exists.

Affected packages and fixed versions:
- mermaid (npm): affected from 11.5.0; fixed in 11.16.1
- mermaid (npm): affected from 11.5.0; fixed in 11.16.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71437/ (Markdown: https://insights.sbomify.com/CVE-2026-71437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71437
- OSV: https://osv.dev/vulnerability/CVE-2026-71437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71437/
Summaries are generated and may contain mistakes; the official description above is the record.
