CVE-2026-71438 Mermaid configuration APIs allow prototype pollution

Low 2.4 Published Updated

Prototype pollution in Mermaid configuration APIs allows code execution if untrusted data is forwarded to config setters.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-71438?

CVE-2026-71438 is a low-severity code injection vulnerability in mermaid-js mermaid, published on 6 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Prior to 10.9.8 and 11.16.1, Mermaid's configuration setters (mermaid.initialize, mermaidAPI.setConfig, and mermaidAPI.updateSiteConfig) merge caller-supplied configuration into Mermaid's internal config using the assignWithDepth deep-merge helper, which is vulnerable to prototype pollution. This is only exploitable if an application forwards untrusted data directly into one of these configuration entry points, which is outside their documented usage; diagram-supplied configuration (e.g. %%{init: {}}%% or YAML frontmatter) is not affected. This issue is fixed in versions 10.9.8 and 11.16.1.

Weakness: CWE-1321

Which versions are affected by CVE-2026-71438?

4 open source packages ship an affected version, including mermaid.

PackageAffectedFixed in
mermaid npmAll versions10.9.8
mermaid npmAll versions10.9.8
mermaid npmFrom 11.0.0-alpha.111.16.1
mermaid npmFrom 11.0.0-alpha.111.16.1

How do I fix CVE-2026-71438?

Upgrade mermaid to a fixed version for your release line: 10.9.8 or 11.16.1.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-71438 being exploited?

There is no known exploitation of CVE-2026-71438 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2026-VV35394, DEBIAN-CVE-2026-71438, GHSA-c4c3-pg64-4m4v, MINI-3fhf-8668-68p2, MINI-8x6w-8ggq-hjxr, MINI-q26w-9w8x-49c8 and 2 more.

Is CVE-2026-71438 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free