{"answers":{"affected":"4 open source packages ship an affected version, including mermaid.","exploited":"There is no known exploitation of CVE-2026-71438 in the wild and no public exploit code.","fix":"Upgrade mermaid to a fixed version for your release line: 10.9.8 or 11.16.1.","what":"CVE-2026-71438 is a low-severity code injection vulnerability in mermaid-js mermaid, published on 6 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-71438 and fix it if it is affected.\n\nWhat it is: CVE-2026-71438 is a low-severity code injection vulnerability in mermaid-js mermaid, published on 6 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-71438 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mermaid (npm): affected all versions; fixed in 10.9.8\n- mermaid (npm): affected all versions; fixed in 10.9.8\n- mermaid (npm): affected from 11.0.0-alpha.1; fixed in 11.16.1\n- mermaid (npm): affected from 11.0.0-alpha.1; fixed in 11.16.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-71438/ (Markdown: https://insights.sbomify.com/CVE-2026-71438/index.md)","id":"CVE-2026-71438","markdown":"https://insights.sbomify.com/CVE-2026-71438/index.md","name":"CVE-2026-71438","record":{"aliases":["CLEANSTART-2026-VV35394","DEBIAN-CVE-2026-71438","GHSA-c4c3-pg64-4m4v","MINI-3fhf-8668-68p2","MINI-8x6w-8ggq-hjxr","MINI-q26w-9w8x-49c8","MINI-w7h7-6436-p562","UBUNTU-CVE-2026-71438"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"JavaScript diagramming library","requires_auth":"high_privilege","summary":"Prototype pollution in Mermaid configuration APIs allows code execution if untrusted data is forwarded to config setters.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.4,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:A/VC:N/VI:L/VA:L/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Prior to 10.9.8 and 11.16.1, Mermaid's configuration setters (mermaid.initialize, mermaidAPI.setConfig, and mermaidAPI.updateSiteConfig) merge caller-supplied configuration into Mermaid's internal config using the assignWithDepth deep-merge helper, which is vulnerable to prototype pollution. This is only exploitable if an application forwards untrusted data directly into one of these configuration entry points, which is outside their documented usage; diagram-supplied configuration (e.g. %%{init: {}}%% or YAML frontmatter) is not affected. This issue is fixed in versions 10.9.8 and 11.16.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mermaid configuration APIs allow prototype pollution","id":"CVE-2026-71438","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":4,"n_references":6,"next":{"headline":"Mermaid radar diagrams are vulnerable to DoS","id":"CVE-2026-71439"},"packages":[{"ecosystem":"npm","fixed":["10.9.8"],"introduced":["0"],"last_affected":[],"package":"mermaid","purl":null,"source":"GHSA-c4c3-pg64-4m4v"},{"ecosystem":"npm","fixed":["10.9.8"],"introduced":["0"],"last_affected":[],"package":"mermaid","purl":"pkg:npm/mermaid","source":"GHSA-c4c3-pg64-4m4v"},{"ecosystem":"npm","fixed":["11.16.1"],"introduced":["11.0.0-alpha.1"],"last_affected":[],"package":"mermaid","purl":null,"source":"GHSA-c4c3-pg64-4m4v"},{"ecosystem":"npm","fixed":["11.16.1"],"introduced":["11.0.0-alpha.1"],"last_affected":[],"package":"mermaid","purl":"pkg:npm/mermaid","source":"GHSA-c4c3-pg64-4m4v"}],"prev":{"headline":"Mermaid Architecture diagrams are vulnerable to prototype pollution","id":"CVE-2026-71437"},"products":["mermaid"],"published":"2026-08-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-07","vendors":["mermaid-js"]},"summary":"Prototype pollution in Mermaid configuration APIs allows code execution if untrusted data is forwarded to config setters.","url":"https://insights.sbomify.com/CVE-2026-71438/"}