# CVE-2026-71439: Mermaid radar diagrams are vulnerable to DoS

> Attackers can cause denial of service in Mermaid radar diagrams by supplying large tick values, freezing the rendering process.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 7 Aug 2026
- **Also known as:** CLEANSTART-2026-VU48904, DEBIAN-CVE-2026-71439, GHSA-rhh3-jpg6-66xh, MINI-j3xg-fphv-8vw4, MINI-vh8f-vjh6-396q, UBUNTU-CVE-2026-71439

## What is CVE-2026-71439?

CVE-2026-71439 is a medium-severity denial of service vulnerability in mermaid-js mermaid, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. From version 11.6.0 until 11.16.1, Mermaid Radar Diagrams allow arbitrary large values for the ticks parameter, which can cause high CPU usage and freeze the rendering webpage or JavaScript process for long periods of time, potentially until the process is killed from memory exhaustion. This issue is fixed in version 11.16.1.

Weakness: CWE-606 (Unchecked Input for Loop Condition), CWE-1322 (Use of Blocking Code in Single-threaded, Non-blocking Context)

## Which versions are affected by CVE-2026-71439?

2 open source packages ship an affected version, including mermaid.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mermaid` | npm | From 11.6.0 | 11.16.1 |
| `mermaid` | npm | From 11.6.0 | 11.16.1 |

## How do I fix CVE-2026-71439?

Upgrade mermaid to 11.16.1 or later.

## Is CVE-2026-71439 being exploited?

There is no known exploitation of CVE-2026-71439 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71439 and fix it if it is affected.

What it is: CVE-2026-71439 is a medium-severity denial of service vulnerability in mermaid-js mermaid, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-71439 in the wild and no public exploit code.

Affected packages and fixed versions:
- mermaid (npm): affected from 11.6.0; fixed in 11.16.1
- mermaid (npm): affected from 11.6.0; fixed in 11.16.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71439/ (Markdown: https://insights.sbomify.com/CVE-2026-71439/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71439
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71439
- OSV: https://osv.dev/vulnerability/CVE-2026-71439

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71439/
Summaries are generated and may contain mistakes; the official description above is the record.
