# CVE-2026-71476: Nx: Zip-Slip in the self-hosted remote cache

> Attackers can achieve remote code execution via path traversal in the self-hosted remote cache of the Nx monorepo tool.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 8 Aug 2026
- **Also known as:** GHSA-vp3h-ghgh-jr7g, ROOT-APP-NPM-CVE-2026-71476

## What is CVE-2026-71476?

CVE-2026-71476 is a high-severity path traversal vulnerability in nrwl nx, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Nx is a monorepo solution for TypeScript and polyglot codebases. From version 20.8.0 until 22.7.7 and 23.0.2, the Nx self-hosted HTTP remote cache extracts downloaded cache artifacts without constraining where files are written. A malicious or on-path (MITM) remote cache server can return a crafted tar archive whose entries escape the cache directory and write to arbitrary locations on the machine running Nx, which can be escalated to remote code execution. Nx's default local cache and Nx Cloud are not affected; only workspaces configured to use a self-hosted remote cache are affected. This issue is fixed in versions 22.7.7 and 23.0.2.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-71476?

20 open source packages ship an affected version, including nx, @nx/azure-cache and @nx/gcs-cache.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nx` | npm | From 20.8.0 | 22.7.7 |
| `nx` | npm | From 20.8.0 | 22.7.7 |
| `nx` | npm | From 23.0.0 | 23.0.2 |
| `nx` | npm | From 23.0.0 | 23.0.2 |
| `@nx/azure-cache` | npm | All versions to 5.0.7 | None |
| `@nx/azure-cache` | npm | All versions to 5.0.7 | None |
| `@nx/gcs-cache` | npm | All versions to 5.0.7 | None |
| `@nx/gcs-cache` | npm | All versions to 5.0.7 | None |
| `@nx/powerpack-azure-cache` | npm | All versions to 5.0.7 | None |
| `@nx/powerpack-azure-cache` | npm | All versions to 5.0.7 | None |
| `@nx/powerpack-gcs-cache` | npm | All versions to 5.0.7 | None |
| `@nx/powerpack-gcs-cache` | npm | All versions to 5.0.7 | None |
| `@nx/powerpack-s3-cache` | npm | All versions to 5.0.7 | None |
| `@nx/powerpack-s3-cache` | npm | All versions to 5.0.7 | None |
| `@nx/powerpack-shared-fs-cache` | npm | All versions to 5.0.7 | None |
| `@nx/powerpack-shared-fs-cache` | npm | All versions to 5.0.7 | None |
| `@nx/s3-cache` | npm | All versions to 5.0.7 | None |
| `@nx/s3-cache` | npm | All versions to 5.0.7 | None |
| `@nx/shared-fs-cache` | npm | All versions to 5.0.7 | None |
| `@nx/shared-fs-cache` | npm | All versions to 5.0.7 | None |

## How do I fix CVE-2026-71476?

Upgrade nx to a fixed version for your release line: 22.7.7 or 23.0.2.

## Is CVE-2026-71476 being exploited?

There is no known exploitation of CVE-2026-71476 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71476 and fix it if it is affected.

What it is: CVE-2026-71476 is a high-severity path traversal vulnerability in nrwl nx, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-71476 in the wild and no public exploit code.

Affected packages and fixed versions:
- nx (npm): affected from 20.8.0; fixed in 22.7.7
- nx (npm): affected from 20.8.0; fixed in 22.7.7
- nx (npm): affected from 23.0.0; fixed in 23.0.2
- nx (npm): affected from 23.0.0; fixed in 23.0.2
- @nx/azure-cache (npm): affected all versions up to 5.0.7; no fix listed
- @nx/azure-cache (npm): affected all versions up to 5.0.7; no fix listed
- @nx/gcs-cache (npm): affected all versions up to 5.0.7; no fix listed
- @nx/gcs-cache (npm): affected all versions up to 5.0.7; no fix listed
- @nx/powerpack-azure-cache (npm): affected all versions up to 5.0.7; no fix listed
- @nx/powerpack-azure-cache (npm): affected all versions up to 5.0.7; no fix listed
- @nx/powerpack-gcs-cache (npm): affected all versions up to 5.0.7; no fix listed
- @nx/powerpack-gcs-cache (npm): affected all versions up to 5.0.7; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71476/ (Markdown: https://insights.sbomify.com/CVE-2026-71476/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71476
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71476
- OSV: https://osv.dev/vulnerability/CVE-2026-71476

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71476/
Summaries are generated and may contain mistakes; the official description above is the record.
