# CVE-2026-71478: league/commonmark: AttributesExtension href/src unsafe-link filter bypass via embedded control bytes

> Attackers can bypass unsafe-link filters in league/commonmark to inject JavaScript via control bytes, leading to XSS in rendered Markdown.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 7 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-71478, GHSA-29pj-957v-52mc, UBUNTU-CVE-2026-71478

## What is CVE-2026-71478?

CVE-2026-71478 is a medium-severity cross-site scripting vulnerability in thephpleague commonmark, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

league/commonmark is a PHP library for parsing and rendering CommonMark Markdown. From 1.5.0 until 2.9.0, the AttributesExtension's href and src unsafe-link filter can be bypassed by embedding control bytes, such as a tab, carriage return, line feed, or leading C0 control character, in a javascript: URL that browsers discard before parsing the scheme, causing the browser to still execute the script even when the unsafe-link filter is enabled. This issue is fixed in 2.9.0.

Weakness: CWE-86 (Improper Neutralization of Invalid Characters in Identifiers in Web Pages), CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-692 (Incomplete Denylist to Cross-Site Scripting)

## Which versions are affected by CVE-2026-71478?

2 open source packages ship an affected version, including league/commonmark.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `league/commonmark` | Packagist | From 1.5.0 | 2.9.0 |
| `league/commonmark` | Packagist | From 1.5.0 | 2.9.0 |

## How do I fix CVE-2026-71478?

Upgrade league/commonmark to 2.9.0 or later.

## Is CVE-2026-71478 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71478 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71478 and fix it if it is affected.

What it is: CVE-2026-71478 is a medium-severity cross-site scripting vulnerability in thephpleague commonmark, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71478 exists.

Affected packages and fixed versions:
- league/commonmark (Packagist): affected from 1.5.0; fixed in 2.9.0
- league/commonmark (Packagist): affected from 1.5.0; fixed in 2.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71478/ (Markdown: https://insights.sbomify.com/CVE-2026-71478/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71478
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71478
- OSV: https://osv.dev/vulnerability/CVE-2026-71478

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71478/
Summaries are generated and may contain mistakes; the official description above is the record.
