# CVE-2026-71486: vLLM: Derender endpoints decode caller-supplied GenerateResponse token IDs without output bounds

> An authenticated attacker can cause excessive resource consumption and oversized responses in vLLM by sending crafted token IDs to derender endpoints before limits are enforced.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-8737-qx52-hjff, MINI-449j-7ph2-97pm, MINI-rhph-wf6r-cg97, MINI-wwj8-fv7x-7m55, PYSEC-2026-3936

## What is CVE-2026-71486?

CVE-2026-71486 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models. Prior to 0.26.0, the /v1/completions/derender and /v1/chat/completions/derender endpoints accept caller-supplied GenerateResponse objects whose generate_responses, choices, token_ids, prompt_logprobs, logprobs.content, top_logprobs, and routed_experts structures are processed by OnlineDerenderer and tokenizer.decode before max_model_len, max_tokens, max_num_seqs, or response-size limits are enforced, allowing an authenticated API client to consume excessive CPU and memory and produce oversized responses. This issue is fixed in version 0.26.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-71486?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.26.0 |
| `vllm` | PyPI | All versions | 0.26.0 |
| `vllm` | PyPI | All versions | 0.26.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-71486?

Upgrade vllm to 0.26.0 or later.

## Is CVE-2026-71486 being exploited?

There is no known exploitation of CVE-2026-71486 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71486 and fix it if it is affected.

What it is: CVE-2026-71486 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-71486 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.26.0
- vllm (PyPI): affected all versions; fixed in 0.26.0
- vllm (PyPI): affected all versions; fixed in 0.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71486/ (Markdown: https://insights.sbomify.com/CVE-2026-71486/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71486
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71486
- OSV: https://osv.dev/vulnerability/CVE-2026-71486

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71486/
Summaries are generated and may contain mistakes; the official description above is the record.
