# CVE-2026-71488: league/commonmark: Quadratic-time denial of service when parsing crafted Markdown

> Attackers can cause excessive CPU consumption via crafted Markdown input in the league/commonmark PHP library, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 7 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-71488, GHSA-2q4p-g7hv-5rgv, UBUNTU-CVE-2026-71488

## What is CVE-2026-71488?

CVE-2026-71488 is a high-severity denial of service vulnerability in thephpleague commonmark, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

league/commonmark is a PHP library for parsing and rendering CommonMark Markdown. From 0.6.0 until 2.9.0, specially crafted Markdown lines can cause the parser to have quadratic time complexity when converting, because several parsing paths repeatedly rescan growing portions of a line to translate between character positions and byte positions, and the Autolink extension can also copy and validate the remaining line at every URL-like prefix, allowing an attacker who can submit Markdown for conversion to consume disproportionate CPU time with a comparatively small request. This issue is fixed in 2.9.0.

Weakness: CWE-407 (Inefficient Algorithmic Complexity), CWE-1050 (Excessive Platform Resource Consumption within a Loop)

## Which versions are affected by CVE-2026-71488?

2 open source packages ship an affected version, including league/commonmark.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `league/commonmark` | Packagist | From 0.6.0 | 2.9.0 |
| `league/commonmark` | Packagist | From 0.6.0 | 2.9.0 |

## How do I fix CVE-2026-71488?

Upgrade league/commonmark to 2.9.0 or later.

## Is CVE-2026-71488 being exploited?

There is no known exploitation of CVE-2026-71488 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71488 and fix it if it is affected.

What it is: CVE-2026-71488 is a high-severity denial of service vulnerability in thephpleague commonmark, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-71488 in the wild and no public exploit code.

Affected packages and fixed versions:
- league/commonmark (Packagist): affected from 0.6.0; fixed in 2.9.0
- league/commonmark (Packagist): affected from 0.6.0; fixed in 2.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71488/ (Markdown: https://insights.sbomify.com/CVE-2026-71488/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71488
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71488
- OSV: https://osv.dev/vulnerability/CVE-2026-71488

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71488/
Summaries are generated and may contain mistakes; the official description above is the record.
