# CVE-2026-71490: OPNsense: Direct comma-separated user privileges bypass OPNsense MVC read-only write protection

> Attackers with specific user privileges can bypass read-only restrictions to modify firewall configuration via MVC APIs.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** GHSA-p9pr-782r-w2xw

## What is CVE-2026-71490?

CVE-2026-71490 is a high-severity authentication bypass vulnerability in opnsense core, published on 15 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.11, OPNsense\Core\ACL::hasPrivilege() appends a directly assigned comma-separated <priv> value as one string and then uses an exact comparison when checking user-config-readonly. A user directly assigned both a component write privilege and user-config-readonly can therefore be treated as lacking the read-only restriction, and MVC APIs protected by throwReadOnly() can persist configuration changes for that component. Group privileges are not affected by the same parser flaw because the group path already splits comma-separated values. This issue is fixed in version 26.1.11.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-71490?


## How do I fix CVE-2026-71490?

No fix has been published for CVE-2026-71490 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-71490 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71490 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71490 and fix it if it is affected.

What it is: CVE-2026-71490 is a high-severity authentication bypass vulnerability in opnsense core, published on 15 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71490 exists.

Affected product: opnsense core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71490/ (Markdown: https://insights.sbomify.com/CVE-2026-71490/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71490
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71490
- OSV: https://osv.dev/vulnerability/CVE-2026-71490

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71490/
Summaries are generated and may contain mistakes; the official description above is the record.
